POJ - 1562 Oil Deposits(连通块经典问题)

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *', representing the absence of oil, or@’, representing an oil pocket.

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0
Sample Output
0
1
2
2
题意

给你个n*m的矩阵,当m=0的时候结束输入,让你求矩阵中连通块的数量。

思路

这是一道连通块经典问题,先找到第一个@,然后bfs将它连通的@都感染掉(改成*),然后再找下一个(第一轮感染过后剩下的)@,重复上述过程,,,最后感染的次数就是答案。

题目不难,依旧是我想整理模板,,,模板一套,题目A掉。(当然了,自己能够理解最好,毕竟自己理解的才是自己的)

代码:

#include<queue>
#include<iostream>
using namespace std;
const int b[8][2]={0,1,0,-1,1,0,-1,0,1,1,1,-1,-1,1,-1,-1};//八个方向 
char mp[105][105];//存输入的初始状态 
int n,m;
struct Node//记录坐标 
{
 int x;
 int y;
};
void bfs(int e,int f)
{
     Node temp;
     temp.x=e;
     temp.y=f;
     queue<Node>q;
     q.push(temp);
     while(q.size())
     {
          Node cur=q.front();
          q.pop();
          mp[cur.x][cur.y]='*';
          for(int i=0;i<8;i++)
          {
              Node next;
              next.x=cur.x+b[i][0];
              next.y=cur.y+b[i][1];
              if(next.x<0||next.y<0||next.y>m||next.x>n)
                      continue;       
              if(mp[next.x][next.y]!='@')
                      continue;
              q.push(next);     
          }
     }
}
int main( )
{
       while((scanf("%d%d",&n,&m))!=EOF)
       {
             if(m==0) break;
             for(int i=0;i<n;i++)
             {
                    scanf("%s",&mp[i]);
             }
             int ans=0;      
             for(int i=0;i<n;i++)
             {
                   for(int j=0;j<m;j++)
                   {
                         if(mp[i][j]=='@')
                         {
                               ans++;
                               bfs(i,j);
                         }
                    }
             }
             printf("%d\n",ans);     
      }
      return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值