UVA 340

340 Master-Mind Hints

MasterMind is a game for two players. One of them, Designer, selects a secret code. The other, Breaker,
tries to break it. A code is no more than a row of colored dots. At the beginning of a game, the players
agree upon the length N that a code must have and upon the colors that may occur in a code.

In order to break the code, Breaker makes a number of guesses, each guess itself being a code. After
each guess Designer gives a hint, stating to what extent the guess matches his secret code.

In this problem you will be given a secret code s1 . . . sn and a guess g1 . . . gn, and are to determine
the hint. A hint consists of a pair of numbers determined as follows.

A match is a pair (i, j), 1 ≤ i ≤ n and 1 ≤ j ≤ n, such that si = gj . Match (i, j) is called strong
when i = j, and is called weak otherwise. Two matches (i, j) and (p, q) are called independent when
i = p if and only if j = q. A set of matches is called independent when all of its members are pairwise
independent.

Designer chooses an independent set M of matches for which the total number of matches and the
number of strong matches are both maximal. The hint then consists of the number of strong followed
by the number of weak matches in M. Note that these numbers are uniquely determined by the secret
code and the guess. If the hint turns out to be (n, 0), then the guess is identical to the secret code.


Input

The input will consist of data for a number of games. The input for each game begins with an integer
specifying N (the length of the code). Following these will be the secret code, represented as N integers,
which we will limit to the range 1 to 9. There will then follow an arbitrary number of guesses, each
also represented as N integers, each in the range 1 to 9. Following the last guess in each game will be
N zeroes; these zeroes are not to be considered as a guess.

Following the data for the first game will appear data for the second game (if any) beginning with a
new value for N. The last game in the input will be followed by a single ‘0’ (when a value for N would
normally be specified). The maximum value for N will be 1000.



Output

The output for each game should list the hints that would be generated for each guess, in order, one hint
per line. Each hint should be represented as a pair of integers enclosed in parentheses and separated by
a comma. The entire list of hints for each game should be prefixed by a heading indicating the game
number; games are numbered sequentially starting with 1. Look at the samples below for the exact format.



Sample Input
4
1 3 5 5
1 1 2 3
4 3 3 5
6 5 5 1
6 1 3 5
1 3 5 5
0 0 0 0
10
1 2 2 2 4 5 6 6 6 9
1 2 3 4 5 6 7 8 9 1
1 1 2 2 3 3 4 4 5 5
1 2 1 3 1 5 1 6 1 9
1 2 2 5 5 5 6 6 6 7
0 0 0 0 0 0 0 0 0 0
0


Sample Output
Game 1:
(1,1)
(2,0)
(1,2)
(1,2)
(4,0)
Game 2:
(2,4)
(3,2)
(5,0)
(7,0)



/*
	题目:给定一个答案序列和用户猜测序列,
	统计有多少数字位置相同数值相同(a),
	有多少数字在两个序列都出现过但位置不对(b)。
	
	下标假设从1开始(不是从0),
	如:	A[1,2,3,4]
		B[1,3,1,3]
		A[1]和B[1]值相同位置相同,那么a++;
		A[3]和B[2]值相同但位置不同,那么b++;
		但必须注意匹配过的数值不能再次匹配,
	如:	A[1]和B[3]的数值相同位置不同,
		但由于A[1]和B[1]已经匹配过一次,
		所以不能再匹配。
		而A[3]和B[4]也是如此。

	思路:值相同位置相同匹配很容易判断,
	而值相同位置不同的判断需要知道A中
	是不是已经被匹配过,所以加了两个布尔数组,
	一个判断数值相同位置相同的情况,
	如:A[i]==B[i]的情况 bool_1[i]=true;
	从而记录数值相同位置相同的匹配情况,
	另一个判断数值相同位置不同的情况,
	如:A[j]==B[i]的情况 bool_2[j]=true;
	然后利用两个数组跳过已经匹配过的数值便可。
 */

import java.util.Scanner;
public class Main
{
	public static void main(String[] args) 
	{
		Scanner cin = new Scanner(System.in);
		int n;
		int cnt=1;
		while((n=cin.nextInt())!=0)
		{
			int []a=new int[n];
			int []b=new int[n];
			System.out.println("Game "+(cnt++)+":");
			for(int i=0;i<n;++i)
				a[i]=cin.nextInt();
			while(true)
			{
				
				boolean []mark1=new boolean[n];
				boolean []mark2=new boolean[n];
				int A=0,B=0;
				//判断相同位置并记录
				for(int i=0;i<n;++i)
				{
					b[i]=cin.nextInt();
					if(a[i]==b[i])
					{
						++A;
						mark1[i]=true;
					}
				}
				//输入都为0时就退出
				boolean flag=true;
				for(int i:b)if(i!=0)flag=false;
				if(flag)break;

				for(int i=0;i<n;++i)
				{
					if(mark1[i])continue;
					for(int j=0;j<n;++j)
					{
						if(!mark1[j]&&b[i]==a[j])
						{
							if(mark2[j])continue;
							mark2[j]=true;
							++B;
							break;
						}
					}
				}
				System.out.println("    ("+A+","+B+")");
			}
		}
	}
}






  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值