uva 11205 - The broken pedometer

 The Broken Pedometer 

The Problem

A marathon runner uses a pedometer with which he is having problems. In the pedometer the symbols are represented by seven segments (or LEDs):

But the pedometer does not work properly (possibly the sweat affected the batteries) and only some of the LEDs are active. The runner wants to know if all the possible symbols:

can be correctly identified. For example, when the active LEDs are:

numbers 2 and 3 are seen as:

so they cannot be distinguished. But when the active LEDs are:

the numbers are seen as:

and all of them have a different representation.

Because the runner teaches algorithms at University, and he has some hours to think while he is running, he has thought up a programming problem which generalizes the problem of his sweat pedometer. The problem consists of obtaining the minimum number of active LEDs necessary to identify each one of the symbols, given a number P of LEDs, and N symbols to be represented with these LEDs (along with the codification of each symbol).

For example, in the previous sample P = 7 and N = 10. Supposing the LEDs are numbered as:

The codification of the symbols is: "0" = 1 1 1 0 1 1 1; "1" = 0 0 1 0 0 1 0; "2" = 1 0 1 1 1 0 1; "3" = 1 0 1 1 0 1 1; "4" = 0 1 1 1 0 1 0; "5" = 1 1 0 1 0 1 1; "6" = 1 1 0 1 1 1 1; "7" = 1 0 1 0 0 1 1; "8" = 1 1 1 1 1 1 1; "9" = 1 1 1 1 0 1 1. In this case, LEDs 5 and 6 can be suppressed without losing information, so the solution is 5.

The Input

The input file consists of a first line with the number of problems to solve. Each problem consists of a first line with the number of LEDs (P), a second line with the number of symbols (N), and N lines each one with the codification of a symbol. For each symbol, the codification is a succession of 0s and 1s, with a space between them. A 1 means the corresponding LED is part of the codification of the symbol. The maximum value of P is 15 and the maximum value of N is 100. All the symbols have different codifications.

The Output

The output will consist of a line for each problem, with the minimum number of active LEDs necessary to identify all the given symbols.

Sample Input

2
7
10
1 1 1 0 1 1 1
0 0 1 0 0 1 0
1 0 1 1 1 0 1
1 0 1 1 0 1 1
0 1 1 1 0 1 0
1 1 0 1 0 1 1
1 1 0 1 1 1 1
1 0 1 0 0 1 0
1 1 1 1 1 1 1
1 1 1 1 0 1 1
6
10
0 1 1 1 0 0
1 0 0 0 0 0
1 0 1 0 0 0
1 1 0 0 0 0
1 1 0 1 0 0
1 0 0 1 0 0
1 1 1 0 0 0
1 1 1 1 0 0
1 0 1 1 0 0
0 1 1 0 0 0

Sample Output

5
4
找出最少的二进制位,使所有的二进制数都不同。
开始一直觉得和Xor有关,怎么找也找不到关系......数据量只有100,枚举所有情况。
可以借助二进制与十进制对应关系+位运算简化模拟过程.p位需要枚举2^P-1种情况,1,10,101,...每种情况的二进制刚好对应1-2^p-1的所有十进制数,
1表示需要的位即需要的LED灯的位置,则读入的100个数据,只有相应位置为1的才会亮,符合与运算的条件只有1和1才会真。然后将将每种亮灯的情况再转换为对应的十进制数去判重,在没有重复的情况中取最小的。
#include<stdio.h>
#include<math.h>
#include<string.h>
int main()
{int num,min,t,f,i,j,k,p,n,m,a[101],b[101],exp[16],visit[65536];
 exp[0]=1;
 for (i=1;i<16;i++)
 exp[i]=exp[i-1]*2;
 scanf("%d",&t);
 while (t--)
 {
  scanf("%d%d",&p,&n);
  for (i=1;i<=n;i++)
  {a[i]=0;
   for (j=p-1;j>=0;j--)
   {scanf("%d",&k);
    a[i]+=exp[j]*k;
   }
  }
  min=15;  memset(visit,0,sizeof(visit));
  for (i=1;i<=pow(2,p);i++)
  {f=1; num=n;
   for (j=1;j<=n;j++)
   {m=a[j]&i;
    b[j]=m;
    if (visit[m]==1) {f=0;num=j; break;}
                else visit[m]=1;
   }
   if (f)
   {f=i; k=0;
    while (f) {k+=f%2; f=f/2;}
    if (k<min) min=k;
   }
   for (j=1;j<=num;j++) //每次最多100个数字改变标记为1,如果用memset有点费时但不超时1.67s这样做的话0.024s
   visit[b[j]]=0;
  }
  printf("%d\n",min);
 }
 return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值