uva 10391 - Compound Words

Problem E: Compound Words

You are to find all the two-word compound words in a dictionary. A two-word compound word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.

Input

Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 120,000 words.

Output

Your output should contain all the compound words, one per line, in alphabetical order.

Sample Input

a
alien
born
less
lien
never
nevertheless
new
newborn
the
zebra

Sample Output

alien
newborn
第一次用的Bkdrhash还不是很熟练,照着敲了一遍,还有很多字符串的哈希函数不熟悉
保存每个读入的字符串,计算出哈希值排序,之后对每个字符串穷举不同的分法,计算哈希值后二分查找是否存在。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[120000],t=-1,sum=0;
char s[120000][30],ch1[30],ch2[30];
int comp(int a,int b)
{return a<b;};
int Bkdrhash(char *str)
{int seed=31,hash=0;
 while (*str)
 hash=hash*seed+*str++;
 return hash&0x7FFFFFFF;
};
int Find(int key,int l,int r)
{int mid=(l+r)/2;
 if (l>r) return 0;
 if (a[mid]==key) return 1;
 else if (a[mid]>key) Find(key,l,mid-1);
                else  Find(key,mid+1,r);
};
int main()
{int i,j,k,l;
 freopen("a.in","r",stdin);
 freopen("a.out","w",stdout);
 while (gets(s[++t]))
 a[t]=Bkdrhash(s[t]);
 sort(a,a+t,comp);
 for (i=0;i<t;i++)
 {l=strlen(s[i]);
  for (j=0;j<l-1;j++)
  {
   for (k=0;k<=j;k++)
   ch1[k]=s[i][k];
   ch1[j+1]='\0';
   for (k=j+1;k<l;k++)
   ch2[k-j-1]=s[i][k];
   ch2[l-j-1]='\0';
   if (Find(Bkdrhash(ch1),0,t-1)+Find(Bkdrhash(ch2),0,t-1)==2) {puts(s[i]);break;} //对于形如a,aaa,aaaa,字符串拆分存在重复,a+aaa,aaa+a,直接break掉,
  }
 }
 fclose(stdin);
 fclose(stdout);
 return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值