uva 387 - A Puzzling Problem


 A Puzzling Problem 

The goal of this problem is to write a program which will take from 1 to 5 puzzle pieces such as those shown below and arrange them, if possible, to form a square. An example set of pieces is shown here.

The pieces cannot be rotated or flipped from their original orientation in an attempt to form a square from the set. All of the pieces must be used to form the square. There may be more than one possible solution for a set of pieces, and not every arrangement will work even with a set for which a solution can be found. Examples using the above set of pieces are shown here.

Input

The input file for this program contains several puzzles (i.e. sets of puzzle pieces) to be solved. The first line of the file is the number of pieces in the first puzzle. Each piece is then specified by listing a single line with two integers, the number of rows and columns in the piece, followed by one or more lines which specify the shape of the piece. The shape specification consists of `0' and `1' characters, with the `1' characters indicating the solid shape of the puzzle (the `0' characters are merely placeholders). For example, piece `A' above would be specified as follows:

2 3
111
101

The pieces should be numbered by the order they are encountered in the puzzle. That is, the first piece in a puzzle is piece #1, the next is piece #2, etc. All pieces may be assumed to be valid and no larger than 4 rows by 4 columns.

The line following the final line of the last piece contains the number of pieces in the next puzzle, again followed by the puzzle pieces and so on. The end of the input file is indicated by a zero in place of the number of puzzle pieces.

Output

Your program should report a solution, if one is possible, in the format shown by the examples below. A 4-row by 4-column square should be created, with each piece occupying its location in the solution. The solid portions of piece #1 should be replaced with `1' characters, of piece #2 with `2' characters, etc. The solutions for each puzzle should be separated by a single blank line.

If there are multiple solutions, any of them is acceptable. For puzzles which have no possible solution simply report ``No solution possible''.

Sample Input

4
2 3
111
101
4 2
01
01
11
01
2 1
1
1
3 2
10
10
11
4
1 4
1111
1 4
1111
1 4
1111
2 3
111
001
5
2 2
11
11
2 3
111
100
3 2
11
01
01
1 3
111
1 1
1
0

Sample Output

1112
1412
3422
3442

No solution possible

1133
1153
2223
2444
所有拼图都要用且只用一次能否拼成4*4正方形;开始理解错了以为随便用任意块拼图,直接暴露回溯,程序写的有点乱,是在之前理解错题意的基础上改的,
 
 
Code: Select all
2 4 4 1111 1111 1111 1111 1 1 1 1 1 1 1 0
Output
Code: Select all
No solution possible No solution possible
#include <string.h>
#include <stdio.h>
#define P for (ii=1;ii<=4;ii++) {for (jj=1;jj<=4;jj++) printf("%d",b[ii][jj]); printf("\n");}
#define p printf("k=%d x=%d y=%d\n",k,x,y);
struct node
{int n,m,size[5][5],num;
}a[6];
int t,f,b[5][5],ii,jj,visit[5];
void dfs(int Num,int sum)
{int x,y,i,j,k,can,c[5][5];
 if ((Num==0)&&(sum==t)) {f=1; P;}
 if (f) return ;
 for (x=1;x<=4;x++)
 for (y=1;y<=4;y++)
 for (k=1;k<=t;k++)
 {
  if ((visit[k]==0)&&(x+a[k].n<=5)&&(y+a[k].m<=5)&&(Num>=a[k].num))
  {
   can=1;
   for (i=1;i<=a[k].n;i++)
   for (j=1;j<=a[k].m;j++)
   if (a[k].size[i][j]*b[x+i-1][y+j-1]>0) {can=0; break;}

   if (can)
   {
    for (i=1;i<=4;i++)
    for (j=1;j<=4;j++)
        c[i][j]=b[i][j];

    for (i=1;i<=a[k].n;i++)
    for (j=1;j<=a[k].m;j++)
    if (a[k].size[i][j]) b[x+i-1][y+j-1]=k;
    visit[k]=1;
    dfs(Num-a[k].num,sum+1);
    if (f) return ;
    visit[k]=0;
    for (i=1;i<=4;i++)
    for (j=1;j<=4;j++)
        b[i][j]=c[i][j];
   }
  }
 }
};
int main()
{int i,j,k,Case=0;
 while (scanf("%d",&t),t)
 {
  if (Case++) printf("\n");
  for (k=1;k<=t;k++)
  {
   scanf("%d%d",&a[k].n,&a[k].m);
   a[k].num=0;
   for (i=1;i<=a[k].n;i++)
   for (j=1;j<=a[k].m;j++)
   {
    scanf("%1d",&a[k].size[i][j]);
    a[k].num+=a[k].size[i][j];
   }
  }
  memset(b,0,sizeof(b));
  memset(visit,0,sizeof(visit));
  f=0;    dfs(16,0);
  if (f==0) printf("No solution possible\n");
 }
 return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值