uva 10382 - Watering Grass

Problem E
Watering Grass
Input:
standard input
Output: standard output
Time Limit: 3 seconds

n sprinklers are installed in a horizontal strip of grass l meters long and w meters wide. Each sprinkler is installed at the horizontal center line of the strip. For each sprinkler we are given its position as the distance from the left end of the center line and its radius of operation.

What is the minimum number of sprinklers to turn on in order to water the entire strip of grass?

Input

Input consists of a number of cases. The first line for each case contains integer numbers n, l and w with n <= 10000. The next n lines contain two integers giving the position of a sprinkler and its radius of operation. (The picture above illustrates the first case from the sample input.)

Output

For each test case output the minimum number of sprinklers needed to water the entire strip of grass. If it is impossible to water the entire strip output -1.

Sample input

8 20 2

5 3

4 1

1 2

7 2

10 2

13 3

16 2

19 4

3 10 1

3 5

9 3

6 1

3 10 1

5 3

1 1

9 1

Sample Output

6

2

-1

求最少的圆,覆盖整个矩形,要·全部覆盖,所以要计算出每个圆投影在这个大的矩形上的有效部分的矩形面积,圆可以等效为这个有效矩形,

然后就是贪心了,个数最少当然是假设当前覆盖的长度为m,则找下个矩形的起始点小于m,终止点最大的那个;

由于是实数精度问题稍微注意下

#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<cmath>
#include<string.h>
using namespace std;
struct node
{
 double begin,end;
}a[100001];
int cmp(node x,node y)
{return x.begin<y.begin;}
int main()
{
 int s,i,j,n,l,tail,t,f,max;
 double d,o,r,w;
 while (scanf("%d%d%lf\n",&n,&l,&w)!=EOF)
 {
  s=0;
  memset(a,0,sizeof(a));
  while (n--)
  {
   scanf("%lf%lf",&o,&r);
   if (2*r>=w)
   {
    d=sqrt(r*r-w*w/4);
     a[s].begin=o-d;//计算左右边界
     a[s].end=o+d;
	if (a[s].begin<0) a[s].begin=0;
    if (a[s].end>l)   a[s].end=l;
	++s;
   }
  }
  sort(a,a+s,cmp); 
  i=0;  tail=0; n=1;
  if (a[i].begin==0)
  {
   while (i<s&&a[i].begin==0)
   {
    if (a[i].end>a[tail].end) tail=i;
    ++i;
   }
   t=tail; max=tail;
  while (a[tail].end<l)
  {  
   f=1;
   while (t+1<s&&a[t+1].begin<=a[tail].end) 
   {
    ++t; f=0; 
    if (a[t].end>a[max].end)
     max=t;
   }
   t=max; tail=max; ++n;
   if (f) goto there;//感觉goto蛮方便的;
  }
  printf("%d\n",n);
  }
  else
  {
   there :;
   printf("-1\n");
  }
 }
 return 0;
} 



 

 


 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值