Watering Grass UVA-10382

n sprinklers are installed in a horizontal strip of grass l meters long and w meters wide. Each sprinkler
is installed at the horizontal center line of the strip. For each sprinkler we are given its position as the
distance from the left end of the center line and its radius of operation.
What is the minimum number of sprinklers to turn on in order to water the entire strip of grass?
Input
Input consists of a number of cases. The first line for each case contains integer numbers n, l and w
with n ≤ 10000. The next n lines contain two integers giving the position of a sprinkler and its radius
of operation. (The picture above illustrates the first case from the sample input.)
Output
For each test case output the minimum number of sprinklers needed to water the entire strip of grass.
If it is impossible to water the entire strip output ‘-1’.
Sample Input
8 20 2
5 3
4 1
1 2
7 2
10 2
13 3
16 2
19 4
3 10 1
3 5
9 3
6 1
3 10 1
5 3
1 1
9 1
Sample Output
6
2
-1

题意: 有一块长方形的草坪,有n个水管,水管在草坪的中线上,每个水管有其覆盖范围,求最少多少个谁管能把草坪覆盖,若不能完全覆盖输出-1.

思路: 求出每个水管与草坪边界的交点,按左交点从小到大排序,便利一遍求出最小水管数。

代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<vector>
#include<algorithm>
using namespace std;
int n;
double m,t;
pair<double,double>a[10010];
int main()
{
    while(~scanf("%d %lf %lf",&n,&m,&t))
    {
        int p=0,ans=0;
        for(int i=1; i<=n; i++)
        {
            double c,d;
            scanf("%lf %lf",&c,&d);
            if(d<=t/2)
                continue;
            a[++p].first=c-sqrt(d*d-t*t/4);//求出每个水管与草坪边界的左右交点
            a[p].second=c+sqrt(d*d-t*t/4);
        }
        sort(a+1,a+p+1);
        double z=0,y=-1;
        for(int i=1; i<=p; i++)
        {
            if(a[i].first>z)
            {
                if(y<=z)
                {
                    ans=-1;
                    break;
                }
                if(y<=m)
                    ans++;
                z=y;//更新当前左右交点
            }
            if(a[i].first<=z)
            {
                y=max(y,a[i].second);
            }
        }
        if(y>=m)//需要覆盖到草坪最右端
            ans++;
        else
            ans=-1;
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值