HDU 2955 - Robberies

Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

Sample Input
  
  
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
 

Sample Output
  
  
2 4 6


菜鸡一下子不敢搞滚动数组……先搞一个二维数组的好了……

//f[i][j]表示前i个银行里抢劫钱j后的最高安全概率
//f[i][j] = max( f[i-1][j] , f[i-1][j-money[i]]*safe_p[i] ) 
//我们已知 1:前i-1个银行里抢劫钱j的最高安全概率,以及 2:前i-1个银行里抢劫(j-当前这个第i号银行的money钱)这么多钱的最高安全概率
//然后我们把 2 这个概率乘上抢劫当前第i号银行的安全概率,就得到 3:抢了当前第i号银行后的安全概率
//我们比较一下1、3的概率哪个大,就是f[i][j]
//最后我们从 j=(max_money....0) 遍历f[n][j],找到第一个出现的j,使得f[n][j]满足f[n][j]>least_safe_p,此时的j就是answer 

//max_money:所有的银行加起来的钱
//least_safe_p:Roy想保证的最低安全概率

#include<cstdio>
#include<cstring>
#define max(a,b) a>b?a:b 
#define N 103
float safe_p[N],f[N][N*N];
int money[N];
int main()
{
	int t;
	scanf("%d",&t);
	while(t--){
		float least_safe_p;int n;
		scanf("%f%d",&least_safe_p,&n);least_safe_p=1-least_safe_p;
		
		int max_money=0;
		for(int i=1;i<=n;i++) {
			scanf("%d%f",&money[i],&safe_p[i]);
			safe_p[i]=1-safe_p[i];
			max_money+=money[i];
		}

		for(int i=0;i<=n;i++) f[i][0]=1;
		for(int i=1;i<=n;i++){
			for(int j=0;j<=max_money;j++){
				if(j<money[i]) f[i][j]=f[i-1][j];
				else f[i][j]=max( f[i-1][j] , f[i-1][j-money[i]]*safe_p[i] );
			}
		}
		//for(int j=0;j<=max_money;j++) printf("%f\n",f[n][j]);
		for(int j=max_money;j>=0;j--){
			if(f[n][j]>=least_safe_p) {printf("%d\n",j);break;}
		}
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值