F - Prime Path P

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.

    1033
    1733
    3733
    3739
    3779
    8779
    8179 

The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased. 

Input
One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).
Output
One line for each case, either with a number stating the minimal cost or containing the word Impossible.
Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0

题意:从一个四位素数变成另外的一个四位素数,最少需要改变多少次。

/*#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<queue>
#include<math.h>
using namespace std;
int beg,res;
int su[11100];
int vis[11000];
struct node
{
   int x,step;
};
int check(int x)
{
    if(x>=1000&&x<10000&&!vis[x]&&su[x])
    return 1;
    else
    return 0;
}

void bfs()
{
    node v,t;
    queue<node>Q;
    t.x = beg;
    t.step = 0;
    vis[beg] = 1;
    while(!Q.empty())
    {
       v = Q.front();
       Q.pop();
       if(v.x == res)
       {
          printf("%d\n",v.step);
          return ;
       }
       for(int i=0;i<=9;i++)
       {
           t = v;
           t.x /= 10;
           t.x = t.x*10+i;
           if(check(t.x))
           {
               vis[t.x] = 1;
               Q.push(t);
               t.step++;
           }

       }
       for(int i=0;i<=9;i++)
       {
           t = v;
           int a = t.x%10;
           t.x = t.x/100;
           t.x = t.x*100+i*10+a;
           if(check(t.x))
           {
               vis[t.x] = 1;
               Q.push(t);
               t.step++;
           }
       }
       for(int i=0;i<=9;i++)
       {

       }

    }

}*/
#include<stdio.h>
#include<math.h>
#include<stdlib.h>
#include<string.h>
#include<queue>
using namespace std;
int beg,res;
int su[10000];
int sign[10000];

struct node
{
    int x,step;
};

int check(int a)
{
    if(a>=1000&&a<10000&&su[a]&&!sign[a])
        return 1;
    return 0;
}

void bfs()
{
    node mm,nn;
    mm.x=beg; mm.step=0;
    queue<node>  jj;
    jj.push(mm);
    sign[beg]=1;
    while(!jj.empty())
    {
        nn=jj.front();
        jj.pop();
        if(nn.x==res)
        {
           printf("%d\n",nn.step);
            return ;
        }


        for(int i=0;i<=9;i++)
        {
            mm=nn;
            mm.x=mm.x/10;///另其个无论是什么都从0开始,所以/10;例如1033/10=103,然后就从1030开始判断。

            mm.x=mm.x*10+i;
            if(check(mm.x))
            {

                mm.step++;
                jj.push(mm);
                sign[mm.x]=1;
            }
        }


        for(int i=0;i<=9;i++)
        {
            mm=nn;
            int a=mm.x%10;
            mm.x=mm.x/100;
            mm.x=mm.x*100+i*10+a;

            if(check(mm.x))
            {

                mm.step++;
                jj.push(mm);
                sign[mm.x]=1;
            }
        }


        for(int i=0;i<=9;i++)
        {
            mm=nn;
            int b=mm.x%100;
            mm.x=mm.x/1000;
            mm.x=mm.x*1000+i*100+b;
            if(check(mm.x))
            {

                mm.step++;
                jj.push(mm);
                sign[mm.x]=1;
            }
        }


        for(int i=1;i<=9;i++)
        {
            mm=nn;
            mm.x=mm.x%1000;
            mm.x=mm.x+i*1000;
            if(check(mm.x))
            {

                mm.step++;
                jj.push(mm);
                sign[mm.x]=1;
            }
        }
    }
   printf("Impossible\n");
}

int main()
{

    memset(su,1,sizeof(su));

    for(int i=2;i<=sqrt(10000);i++)
    {
        if(su[i])
        {
            for(int j=2*i;j<10000;j+=i)
                su[j]=0;
        }
    }

    int n;
    scanf("%d",&n);
    while(n--)
    {
        memset(sign,false,sizeof(sign));
        scanf("%d %d",&beg,&res);
        bfs();
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值