poj Prime Path(BFS)

46 篇文章 0 订阅
Prime Path

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices. 
— It is a matter of security to change such things every now and then, to keep the enemy in the dark. 
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know! 
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door. 
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime! 
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds. 
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime. 

Now, the minister of finance, who had been eavesdropping, intervened. 
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound. 
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you? 
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above. 
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0
ps:不多说什么了,大水题一个,直接枚举就好了。。。
。。。。。坑了我一下午,第一次变量写错,结果找了好久好久,第二次有有个变量忘了变了,结果又单步调试好久。。。 敲打
代码:
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
const int INF=0x3f3f3f3f;
int k[10010],vis[10010];
void is_prime()//素数打表
{
    int i,j;
    for(i=2;i<10010;i++)
        k[i]=1;
    k[1]=0;
    for(i=2; i<10010; i++)
    {
        if(k[i])
        {
            for(j=i+i; j<10010; j+=i)
                k[j]=0;
        }
    }
}
struct node
{
    int x,step;
};
int bfs(int m,int y)
{
    int i;
    node now,next;
    queue<node>q;
    now.x=m,now.step=0;
    q.push(now);
    while(!q.empty())
    {
        now=q.front();
        if(now.x==y)
            return now.step;
        int a=now.x-(now.x/1000)*1000;
        for(i=1000; i<10000; i+=1000)//改变千位
            if(k[i+a]&&vis[i+a]==0)
            {
                vis[i+a]=1;
                next.x=i+a,next.step=now.step+1;
                q.push(next);
            }
        int b=now.x-(now.x/100%10)*100;
        for(i=0; i<1000; i+=100)//改变百位
            if(k[i+b]&&vis[i+b]==0)
            {
                vis[i+b]=1;
                next.x=i+b,next.step=now.step+1;
                q.push(next);
            }
        int c=now.x-(now.x%100/10)*10;
        for(i=0; i<100; i+=10)//改变十位
            if(k[i+c]&&vis[i+c]==0)
            {
                vis[i+c]=1;
                next.x=i+c,next.step=now.step+1;
                q.push(next);
            }
        int d=now.x-now.x%10;
        for(i=1; i<10; i+=2)//改变个位
            if(k[i+d]&&vis[i+d]==0)
            {
                vis[i+d]=1;
                next.x=i+d,next.step=now.step+1;
                q.push(next);
            }
        q.pop();
    }
    return -1;
}
int main()
{
    int t;
    is_prime();
    scanf("%d",&t);
    while(t--)
    {
        int x,y;
        memset(vis,0,sizeof(vis));
        scanf("%d%d",&x,&y);
        vis[x]=1;
        int ans=bfs(x,y);
        if(ans!=-1)
            printf("%d\n",ans);
        else
            printf("Impossible\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值