算法笔记练习 6.2 set 问题 A: 【PAT A1063】Set Similarity

算法笔记练习 题解合集

题目链接

题目

题目描述
Given two sets of integers, the similarity of the sets is defined to be Nc/Nt*100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

输入
Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=104) and followed by M integers in the range [0, 109]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

输出
For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

样例输入

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

样例输出

50.0%
33.3%

思路

步骤:

  1. sets数组接收n个集合的数据;
  2. 对后续的每一条查询,统计两个集合重复的元素个数same,那么总元素个数即为两个集合的.size()之和减去same,计算结果并输出。

第一次写的时候,查询那边的写法是:把查询的两个集合中的元素全部插入到一个新的集合sum里面,然后通过这总共三个集合的.size()之间的数量关系得出答案,然后超时了。

现在的这一版代码用两个迭代器分别遍历两个集合,明显优化了时间复杂度。

代码

#include <cstdio>
#include <set>
using namespace std;

set<int> sets[51];

int main() {
	int n, m, k, input;
	while (scanf("%d", &n) != EOF) {
		for (int i = 1; i != n+1; ++i) {
			scanf("%d", &m);
			while (m--) {
				scanf("%d", &input);
				sets[i].insert(input);
			} 
		}
		scanf("%d", &k);
		while (k--) {
			int a, b, same = 0;
			scanf("%d %d", &a, &b);
			auto ita = sets[a].begin();
			auto itb = sets[b].begin();
			while (ita != sets[a].end() && itb != sets[b].end()) {
				if (*ita == *itb) {
					++same;
					++ita;
					++itb;
				} else if (*ita < *itb) {
					++ita;
				} else {
					++itb;
				} 
			}
			printf("%.1f%%\n", 100.0 * (float)same
				/ (float)(sets[a].size() + sets[b].size() - same));
		} 
	}
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
fsim: a feature similarity index for image quality assessment代码是用于图像质量评估的一种特征相似性指数。 该代码是在图像处理领域中常用的一种评估指标,用于量化图像质量的好坏程度。它基于图像的特征相似性来评估图像的质量,而不是简单地比较图像的像素值。 该代码的实现基于一系列的图像特征。它会对输入的两幅图像进行特征提取,然后计算这些特征之间的相似性。其中特征可以包括颜色、纹理、对比度等。 通过计算特征之间的相似性,可以得到两幅图像的相似度。这个相似度的数值可以作为图像质量的评估指标。如果两幅图像的特征相似度高,那么它们的质量就相似。反之,如果相似度低,则意味着图像质量较差。 这个代码对于图像质量评估非常有用。在图像处理领域中,我们经常需要评估算法对图像质量的影响。通过使用fsim代码,我们可以定量地评估算法对图像质量的改善程度。 同时,这个代码也可以用来比较不同图像处理算法之间的效果。通过计算不同算法处理后图像的质量评估指标,我们可以选择最佳的算法进行图像处理。 总而言之,fsim: a feature similarity index for image quality assessment代码是一种用于图像质量评估的特征相似性指数。它通过计算图像特征之间的相似性来评估图像的质量,可以用于算法的质量评估和算法选择。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值