PAT 乙级练习 题解合集
题目
PAT 准考证号由 4 部分组成:
- 第 1 位是级别,即 T 代表顶级;A 代表甲级;B 代表乙级;
- 第 2~4 位是考场编号,范围从 101 到 999;
- 第 5~10 位是考试日期,格式为年、月、日顺次各占 2 位;
- 最后 11~13 位是考生编号,范围从 000 到 999。
现给定一系列考生的准考证号和他们的成绩,请你按照要求输出各种统计信息。
输入格式:
输入首先在一行中给出两个正整数 N(≤104 )和 M(≤100),分别为考生人数和统计要求的个数。
接下来 N 行,每行给出一个考生的准考证号和其分数(在区间 [0,100] 内的整数),其间以空格分隔。
考生信息之后,再给出 M 行,每行给出一个统计要求,格式为:类型 指令
,其中
类型
为 1 表示要求按分数非升序输出某个指定级别的考生的成绩,对应的指令
则给出代表指定级别的字母;类型
为 2 表示要求将某指定考场的考生人数和总分统计输出,对应的指令
则给出指定考场的编号;类型
为 3 表示要求将某指定日期的考生人数分考场统计输出,对应的指令
则给出指定日期,格式与准考证上日期相同。
输出格式:
对每项统计要求,首先在一行中输出 Case #: 要求
,其中 #
是该项要求的编号,从 1 开始;要求
即复制输入给出的要求。随后输出相应的统计结果:
类型
为 1 的指令,输出格式与输入的考生信息格式相同,即准考证号 成绩
。对于分数并列的考生,按其准考证号的字典序递增输出(题目保证无重复准考证号);类型
为 2 的指令,按人数 总分
的格式输出;类型
为 3 的指令,输出按人数非递增顺序,格式为考场编号 总人数
。若人数并列则按考场编号递增顺序输出。
如果查询结果为空,则输出 NA。
输入样例:
8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999
输出样例:
Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA
思路
第一次写的时候直接针对三种查询情况建立了三个嵌套的 STL,然后疯狂超时…正解是把数据先全部读进来,然后根据查询生成结果并输出。
用第二种思路写了之后写还是超时,于是跑去看 柳神代码 ,把<map>
改成<unordered_map>
,把cmp
函数写成引用传值,AC 了。
注意格式化输出,即考场号不足 3 位要用前导零填充,日期亦是如此。
代码
#include <iostream>
#include <vector>
#include <string>
#include <utility>
#include <unordered_map>
#include <algorithm>
using namespace std;
struct Room {
int no, cnt;
};
bool cmp1(pair<string, int>& a, pair<string, int>& b) {
return a.second != b.second ? a.second > b.second : a.first < b.first;
}
bool cmp2(Room& a, Room& b) {
return a.cnt != b.cnt ? a.cnt > b.cnt : a.no < b.no;
}
int main() {
bool flag;
int n, m, caseCnt = 1, order, manCnt, sum, inputInt;
char inputChar;
cin >> n >> m;
vector<pair<string, int> > testees(n);
for (int i = 0; i < n; ++i)
cin >> testees[i].first >> testees[i].second;
while (m--) {
manCnt = sum = 0;
flag = true;
scanf("%d ", &order);
printf("Case %d: %d ", caseCnt++, order);
switch (order) {
case 1:
scanf("%c", &inputChar);
printf("%c\n", inputChar);
sort(testees.begin(), testees.end(), cmp1);
for (int i = 0; i < n; ++i)
if (testees[i].first[0] == inputChar) {
flag = false;
printf("%s %d\n", testees[i].first.c_str(), testees[i].second);
}
if (flag)
puts("NA");
break;
case 2:
scanf("%d", &inputInt);
printf("%03d\n", inputInt);
for (int i = 0; i < n; ++i)
if (stoi(testees[i].first.substr(1,3)) == inputInt) {
++manCnt;
sum += testees[i].second;
}
if (manCnt)
printf("%d %d\n", manCnt, sum);
else
puts("NA");
break;
case 3:
scanf("%d", &inputInt);
printf("%06d\n", inputInt);
unordered_map<int, int> rooms;
for (int i = 0; i < n; ++i)
if (stoi(testees[i].first.substr(4,6)) == inputInt) {
flag = false;
++rooms[stoi(testees[i].first.substr(1,3))];
}
if (flag)
puts("NA");
else {
vector<Room> sortVec;
for (auto it = rooms.begin(); it != rooms.end(); ++it)
sortVec.push_back( {it->first, it->second} );
sort(sortVec.begin(), sortVec.end(), cmp2);
for (auto it = sortVec.begin(); it != sortVec.end(); ++it)
printf("%03d %d\n", it->no, it->cnt);
}
break;
}
}
return 0;
}