POJ 2421 Constructing Roads(Kruskal变形)

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.
We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.
Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output
179

这题就是在给定一部分路径的情况下,求剩余部分的最小生成树,可以用Kruskal算法,在前面对给出的点进行合并并减去已经给出的边的数量即可,但一定要注意,在任何要合并点的情况下都要判断数据是否合理/是否有重复。
下面是代码:

#include<iostream>
#include<algorithm>
using namespace std;
struct edge{
	int p1;
	int p2;
	int value;
}dat[10005];
int p[105];
int kk;
int dat_i=0;
void init(int n)
{
	for(int i=1;i<=n;++i)
		p[i]=i;
}
int find(int v)
{
	if(p[v]==v) return v;
	else
	{
		p[v]=find(p[v]);
		return p[v];
	}
}
bool merge(int x,int y)
{
	int t1=find(x);
	int t2=find(y);
	if(t1!=t2)
	{
		p[t2]=t1;
		return true;
	}
	return false;
}
bool cmp(edge a,edge b)
{
	return a.value<b.value;
}
int main()
{
	int n,q,from,to,sum=0;
	cin>>n;
	init(n);
	for(int i=1;i<=n;++i)
	{
		for(int j=1;j<=n;++j)
		{
			cin>>kk;
			if(kk!=0)
			{
				dat[dat_i].p1=i;
				dat[dat_i].p2=j;
				dat[dat_i++].value=kk;
			}
		}
	}
	cin>>q;
	for(int i=1;i<=q;++i)
	{
		cin>>from>>to;
		if(merge(from,to))//别忘加这句,判断数据是否合理、是否有重复 
		{
			n--;
		}
	}
	sort(dat,dat+dat_i,cmp);
	for(int i=0;i<dat_i;++i)
	{
		if(merge(dat[i].p1,dat[i].p2))
		{
			n--;
			sum+=dat[i].value;
		}
		if(n==1)
		{
			break;
		}
	}
	cout<<sum<<endl;
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值