BestCoder Round #54 (div.2) HDOJ5430 Reflect(欧拉函数+脑洞)

46 篇文章 0 订阅
29 篇文章 0 订阅

Reflect

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 274    Accepted Submission(s): 162


Problem Description
We send a light from one point on a mirror material circle,it reflects  N  times and return the original point firstly.Your task is calcuate the number of schemes.


 

Input
First line contains a single integer  T(T10)  which denotes the number of test cases. 

For each test case, there is an positive integer  N(N106) .
 

Output
For each case, output the answer.
 

Sample Input
  
  
1 4
 

Sample Output
  
  
4
 



官方贴出的题解:




套个欧拉函数即可。


AC代码:


#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"
using namespace std;
const int MAXN = 1e6 + 6;
int n, a[MAXN];
void work()
{
	for(int i = 1; i < MAXN; ++i)
		a[i] = i;
	for(int i = 2; i < MAXN; i += 2)
		a[i] >>= 1;
	for(int i = 3; i < MAXN; i += 2)
		if(a[i] == i) 
			for(int j = i; j < MAXN; j += i)
				a[j] -= a[j] / i;
}
int main(int argc, char const *argv[])
{
	int t;
	scanf("%d", &t);
	work();
	while(t--) {
		scanf("%d", &n);
		printf("%d\n", a[n + 1]);
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值