HDU5430-----Reflect

Reflect

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 219    Accepted Submission(s): 140



Problem Description
We send a light from one point on a mirror material circle,it reflects N times and return the original point firstly.Your task is calcuate the number of schemes.


 

Input
First line contains a single integer T(T10) which denotes the number of test cases.

For each test case, there is an positive integer N(N106) .
 

Output
For each case, output the answer.
 

Sample Input
  
  
1 4
 

Sample Output
  
  
4
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5431  5429  5426  5425  5424


官方题解:

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
using namespace std;
const int N=1e6+5;
int phi[N];
void getphi()
{
    memset(phi,0,sizeof(phi));
    phi[1]=1;
    for(int i=2;i<N;i++)
    {
        if(!phi[i])
        {
            for(int j=i;j<N;j+=i)
            {
                if(!phi[j])phi[j]=j;
                phi[j]=phi[j]/i*(i-1);
            }
        }
    }
}
int main()
{
    getphi();
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
         scanf("%d",&n);
         printf("%d\n",phi[n+1]);

    }
    return 0;
}

 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值