BestCoder Round #64 (div.2) HDOJ5585 Numbers(模拟)

34 篇文章 0 订阅
29 篇文章 0 订阅

Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 449    Accepted Submission(s): 280


Problem Description
There is a number N.You should output "YES" if N is a multiple of 2, 3 or 5,otherwise output "NO".
 

Input
There are multiple test cases, no more than 1000 cases.
For each case,the line contains a integer N. (0<N<1030)
 

Output
For each test case,output the answer in a line.
 

Sample Input
  
  
2 3 5 7
 

Sample Output
  
  
YES YES YES NO
 



题目链接:点击打开链接

根据题目范围, 字符串读入, 判断是不是2的倍数只要判断最后一位是不是0, 2, 4, 6, 8, 判断是不是5的倍数只要判断最后一位是不是5, 判断是不是3的倍数只要判断每位和是不是3的倍数即可.

AC代码:

#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"
#include "queue"
#include "stack"
#include "cmath"
#include "utility"
#include "map"
#include "set"
#include "vector"
#include "list"
using namespace std;
typedef long long ll;
const int MOD = 1e9 + 7;
const int INF = 0x3f3f3f3f;
const int MAXN = 50;
char s[MAXN];
int main(int argc, char const *argv[])
{
    while(scanf("%s", s) != EOF) {
        int len = strlen(s), sum = 0;
        char c = s[len - 1];        
        for(int i = 0; i < len; ++i)
            sum += s[i] - '0';
        if(c == '0' || c == '2' || c == '4' || c == '5' || c == '6' || c == '8' || sum % 3 == 0) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值