BestCoder Round #63 (div.2) HDOJ5570 balls(数学期望)

29 篇文章 0 订阅
12 篇文章 0 订阅

balls

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 90    Accepted Submission(s): 59


Problem Description
There are  n  balls with  m  colors. The possibility of that the color of the  i -th ball is color  j  is  ai,jai,1+ai,2+...+ai,m . If the number of balls with the  j -th is  x , then you should pay  x2  as the cost. Please calculate the expectation of the cost.
 

Input
Several test cases(about  5 )

For each cases, first come 2 integers,  n,m(1n1000,1m1000)

Then follows  n  lines with  m  numbers  ai,j(1ai100)
 

Output
For each cases, please output the answer with two decimal places.
 

Sample Input
  
  
2 2 1 1 3 5 2 2 4 5 4 2 2 2 2 4 1 4
 

Sample Output
  
  
3.00 2.96 3.20
 



题目链接:点击打开链接

求数学期望的题目, 根据题目概率定义求出第i个球颜色为j的概率, 而后根据题目给出的贡献计算期望.

AC代码:

#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"
#include "cmath"
#include "utility"
#include "map"
#include "set"
#include "vector"
#include "list"
using namespace std;
typedef long long ll;
const int MOD = 1e9 + 7;
const int MAXN = 1005;
int n, m;
double a[MAXN][MAXN], p[MAXN][MAXN];
int main(int argc, char const *argv[])
{
	while(scanf("%d%d", &n, &m) != EOF) {
		for(int i = 0; i < n; ++i) {
			double sum = 0;
			for(int j = 0; j < m; ++j) {
				scanf("%lf", &a[i][j]);
				sum += a[i][j];
			}
			for(int j = 0; j < m; ++j)
				p[i][j] = a[i][j] / sum;
		}
		double ans = 0;
		for(int j = 0; j < m; ++j) {
			double sum = 0;
			for(int i = 0; i < n; ++i)
				ans += p[i][j] * (1.0 - p[i][j]);
			for(int i = 0; i < n; ++i)
				sum += p[i][j];
			ans += sum * sum;
		}
		printf("%.2lf\n", ans);
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值