POJ-2388 Who's in the Middle(简单排序)

Who's in the Middle
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 45193 Accepted: 26019

Description

FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less. 

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.

Input

* Line 1: A single integer N 

* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.

Output

* Line 1: A single integer that is the median milk output.

Sample Input

5
2
4
1
3
5

Sample Output

3

Hint

INPUT DETAILS: 

Five cows with milk outputs of 1..5 

OUTPUT DETAILS: 

1 and 2 are below 3; 4 and 5 are above 3.

代码:

快速排序:

#include <algorithm>
#include <iostream>
#include <cstdio>
#include <string>
#include <vector>
#include <queue>
#include <map>
#include <set>
#include<cmath>
#include <stack>
#include<cstdlib>
#include <cstring>
#include<ctime>
using namespace std;
const int N = 10005;
int num[N],n;
void swap(int *a,int *b){
	int *t = a;
	a = b;
	b = t;
}
void quicksort(int left,int right){
	if(left>=right) return;
	else{
		int i = left;
		int j = right;
		int temp = num[left];
		while(i!=j){
			while(i<j&&num[j]>=temp) j--;
			while(i<j&&num[i]<=temp) i++;
			if(i!=j){
				swap(num[i],num[j]);
			} 
		}
		num[left] = num[i];
		num[i] = temp;
		quicksort(left,i-1);
		quicksort(i+1,right);
		return;
	}
}
int main(){
	cin>>n;
	for(int i = 0;i<n;i++) cin>>num[i];
	quicksort(0,n-1);
	cout<<num[n/2]<<endl;
	return 0;
}

归并排序:

#include <algorithm>
#include <iostream>
#include <cstdio>
#include <string>
#include <vector>
#include <queue>
#include <map>
#include <set>
#include<cmath>
#include <stack>
#include<cstdlib>
#include <cstring>
#include<ctime>
using namespace std;
const int N = 10005;
int num[N],n;
void merge(int low,int mid,int high){
	int *temp = new int[high-low+1];
	int i = low;
	int j = mid+1;
	int k =0;
	while(i<=mid&&j<=high){
		if(num[i]<=num[j]) temp[k++] = num[i++];
		else temp[k++] = num[j++];
	}
	while(i<=mid) temp[k++] = num[i++];
	while(j<=high) temp[k++] = num[j++];
	for(k = 0,i=low;i<=high;k++,i++){
		num[i] = temp[k];
	}
}

void sort(int low,int high){
	if(high>low){
		int mid = (low+high)/2;
		sort(low,mid);
		sort(mid+1,high);
		merge(low,mid,high);
	}
}

int main(){
	cin>>n;
	for(int i = 0;i<n;i++) cin>>num[i];
	sort(0,n-1);
	cout<<num[n/2]<<endl;
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值