POJ-2299 Ultra-QuickSort(离散化+树状数组)

Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 67527 Accepted: 25288

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

代码:

#include <algorithm>  
#include <string.h>  
#include <iostream>  
#include <stdio.h>  
#include <string>  
#include <vector>  
#include <queue>  
#include <map>  
#include <set>  
#include<cmath>  
#include<cstdlib>  
using namespace std;
const int N = 1000005;
//离散化用的结构
struct node {
	int val;
	int pos;
}d[N];

int num[N],bit[N], n;//存放离散化后的数,树状数组 
int cmp(node x, node y) {
	return x.val < y.val;
}
int lowbit(int x) {
	return x&(-x);
}

void add(int x) {
	while (x <= n) {
		bit[x] += 1;
		x += lowbit(x);
	}
}

int  sum(int x) {
	int res = 0;
	while (x>0) {
		res += bit[x];
		x -= lowbit(x);
	}
	return res;
}

void init() {
	for (int i = 1; i <= n; i++) bit[i] = 0;
}

int main() {
	while (cin >> n, n) {
		//输入数组
		for (int i = 1; i <= n; i++) {
			d[i].pos = i;
			cin >> d[i].val;
		}
		//排序
		sort(d + 1, d + 1 + n, cmp);
		//离散化
		for (int i = 1; i <= n; i++) num[d[i].pos] = i;
		long long ans = 0;
		//初始化树状数组
		init();
		//进行计算
		for (int i = 1; i <= n; i++) {
			add(num[i]);
			ans += (i - sum(num[i]));
		}
		cout << ans << endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值