POJ - 2251 Dungeon Master BFS

POJ - 2251 Dungeon Master

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C
.

Output
The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line

Trapped!
Sample Input
3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0
Sample Output
Escaped in 11 minute(s).
Trapped!

首先这道题不要被这个三维给吓住了,就是一个广搜题,之前广搜是每一次走上下左右,这一次多了一个上一层,一个下一层。
第一次用深搜写的,超时了,这种求最小值得问题明显得要用广搜
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
char map[31][31][31];
int book[31][31][31];
struct node{
	int l;
	int x;
	int y;
	int count;
};
int el,ex,ey;
const int INF = 0x3f3f3f;
int next[6][3]={
  {0,1,0},{0,0,1},{0,-1,0},{0,0,-1},
  {1,0,0},{-1,0,0},
};
int L,R,C;
int sl,sx,sy;
int flag;
int ans;
int bfs()
{
	flag=0;
	queue<node> q;
	struct node t1,t2,t3;
	t1.l=sl;
	t1.x=sx;
	t1.y=sy;
	book[t1.l][t1.x][t1.y]=1;
	t1.count=0;
	q.push(t1);
	while(!q.empty())
	{
		t2=q.front();
		q.pop();
		
		for(int i=0;i<6;i++)
		{
			t3.l=t2.l+next[i][0];
			t3.x=t2.x+next[i][1];
			t3.y=t2.y+next[i][2];
			t3.count=t2.count+1;
			
		    if(t3.l<0||t3.x<0||t3.y<0||t3.l>=L||t3.x>=R||t3.y>=C||book[t3.l][t3.x][t3.y]||map[t3.l][t3.x][t3.y]=='#')
			   continue;
		
			book[t3.l][t3.x][t3.y]=1;
			q.push(t3);
			if(map[t3.l][t3.x][t3.y]=='E') {
				flag=1;
				ans=t3.count;
				break;
			}
		   
		}
		if(flag) break;
	}
}
int main(void)
{
	int i,j,k;
	while(scanf("%d%d%d",&L,&R,&C)!=EOF)
	{
		memset(book,0,sizeof(book));
		getchar();
		if(L==0&&R==0&&C==0) break;
		flag=0;
		for(i=0;i<L;i++)
		{
			for(j=0;j<R;j++)
			{
				scanf("%s",&map[i][j]);
				for(k=0;map[i][j][k];k++)
				{
					if(map[i][j][k]=='S')
					{
						sl=i;
						sx=j;
						sy=k;
					}
					if(map[i][j][k]=='E')
					{
						el=i;
						ex=j;
						ey=k;
					}
				}
				getchar();
			}
			getchar();
		}
		book[sl][sx][sy]=1;
		bfs();
		if(flag) printf("Escaped in %d minute(s).\n",ans);
		else  printf("Trapped!\n");
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值