HDU 6201 transaction (spfa最长路) 2017 ACM/ICPC Asia Regional Shenyang Online

transaction transaction transaction

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 132768/132768 K (Java/Others)
Total Submission(s): 2127    Accepted Submission(s): 980


Problem Description
Kelukin is a businessman. Every day, he travels around cities to do some business. On August 17th, in memory of a great man, citizens will read a book named "the Man Who Changed China". Of course, Kelukin wouldn't miss this chance to make money, but he doesn't have this book. So he has to choose two city to buy and sell. 
As we know, the price of this book was different in each city. It is  ai  yuan in  i t city. Kelukin will take taxi, whose price is  1 yuan per km and this fare cannot be ignored.
There are  n1 roads connecting  n cities. Kelukin can choose any city to start his travel. He want to know the maximum money he can get.
 

Input
The first line contains an integer  T ( 1T10) , the number of test cases. 
For each test case:
first line contains an integer  n ( 2n100000) means the number of cities;
second line contains  n numbers, the  i th number means the prices in  i th city;  (1Price10000) 
then follows  n1 lines, each contains three numbers  x y and  z which means there exists a road between  x and  y, the distance is  z km  (1z1000)
 

Output
For each test case, output a single number in a line: the maximum money he can get.
 

Sample Input
 
 
1 4 10 40 15 30 1 2 30 1 3 2 3 4 10
 

Sample Output
 
 
8
 

Source

题意:n个点,n-1条边,每个点有点权代表书的价格,边权代表路上的消耗,一个人选择两个城市,在一个城市买书,到另一个城市去卖书,输出他最多能赚多少钱?

题意:建立一个源点0和一个汇点n+1,源点与n个点连边,权值为-a[i],n个点与汇点连边,权值为a[i],题目中给出的n-1条边建边的时候权值为-cost。用spfa跑一遍最长路就行了。

#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <string.h>
#include <math.h>
#include <string>
#include <vector>
#include <queue>
#include <stack>
#include <set>
#include <map>
using namespace std;
const int INF=0x3f3f3f3f;
const int MAXN=1000005;
int head[MAXN],Count,n;
int dis[MAXN];
bool vis[MAXN];
int a[MAXN];
struct EDGE{
	int v;
	int next;
	int w;
}e[MAXN];
void add_edge(int u,int v,int w)
{
	e[Count].v=v;
	e[Count].w=w;
	e[Count].next=head[u];
	head[u]=Count++;
}
int Spfa(int s)
{
	memset(dis,-INF,sizeof(dis));
	memset(vis,0,sizeof(vis));
	vis[s]=true;
	dis[s] = 0;
	queue<int> q;
	q.push(s);

	while(!q.empty())
	{
		int temp=q.front();
		q.pop();
		vis[temp]=false;

		for(int i=head[temp];i!=-1;i=e[i].next)
		{
		    //printf("--\n");
			int to=e[i].v;
			if(dis[to] < dis[temp] + e[i].w)
			{
			   dis[to] = dis[temp] + e[i].w;
			   if(!vis[to])
			   {
				  vis[to]=true;
				  q.push(to);
			   }
		    }
		}
    }
    return dis[n + 1];
}
int main(void)
{

    int T;
    scanf("%d",&T);
    while(T--) {
        memset(head,-1,sizeof(head));
        Count = 0;

        scanf("%d",&n);
        for(int i = 1; i <= n; i++) {
            scanf("%d",&a[i]);
            add_edge(0,i,-a[i]);
            add_edge(i,n + 1,a[i]);
        }
        for(int i = 0; i < n - 1; i++) {
            int u,v,cost;
            scanf("%d%d%d",&u,&v,&cost);
            add_edge(u,v,-cost);
            add_edge(v,u,-cost);
        }
        printf("%d\n",Spfa(0));
    }
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值