杭电多校第六场 Pinball(物理)

Pinball

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 747    Accepted Submission(s): 331


 

Problem Description

There is a slope on the 2D plane. The lowest point of the slope is at the origin. There is a small ball falling down above the slope. Your task is to find how many times the ball has been bounced on the slope.

It's guarantee that the ball will not reach the slope or ground or Y-axis with a distance of less than 1 from the origin. And the ball is elastic collision without energy loss. Gravity acceleration g=9.8m/s2.

 

 

Input

There are multiple test cases. The first line of input contains an integer T (1 ≤ T ≤ 100), indicating the number of test cases.

The first line of each test case contains four integers a, b, x, y (1 ≤ a, b, -x, y ≤ 100), indicate that the slope will pass through the point(-a, b), the initial position of the ball is (x, y).

 

 

Output

Output the answer.

It's guarantee that the answer will not exceed 50.

 

 

Sample Input

 

1 5 1 -5 3

 

 

Sample Output

 

2

 

 

Source

2018 Multi-University Training Contest 6

思路:垂直于斜面上做周期运动,平行于斜面做匀加速运动,用总时间除每一次的周期时间+1

#include <bits/stdc++.h>
using namespace std;

int main(void)
{
    int T;
    double a,b,x,y,g1,g2,v1,v2,v3,t1,t2;
    int ans;
    scanf("%d",&T);
    while(T--) {
        scanf("%lf %lf %lf %lf",&a,&b,&x,&y);
        double ta = atan2(b , a);
        double dn = 9.8 * (y - (-x) * (b / a));//第一次接触斜面的动能
        g1 = 9.8 * cos(ta);//垂直斜面的加速度
        g2 = 9.8 * sin(ta);//平行斜面的加速度
        v1 = sqrt(2 * dn) * cos(ta);//垂直斜面的的初速度
        v2 = sqrt(2 * dn) * sin(ta);//平行斜面的的初速度
        t1 = 2 * (v1 / g1);//一次周期的时间
        v3 = sqrt(2 * g2 * (-x) / cos(ta) + v2 * v2);//平行斜面的末速度
        t2 = (v3 - v2) / g2;//总时间
        ans = (int)(t2 / t1) + 1;
        printf("%d\n",ans);
    }
    return 0;
}
//1.277753 1.751581
//1.277753 4.551381

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值