HDU - 5876 Sparse Graph(补图最短路)

Sparse Graph

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 2782    Accepted Submission(s): 955

Problem Description

In graph theory, the complement of a graph G is a graph H on the same vertices such that two distinct vertices of H are adjacent if and only if they are not adjacent in G. 

Now you are given an undirected graph G of N nodes and M bidirectional edges of unit length. Consider the complement of G, i.e., H. For a given vertex S on H, you are required to compute the shortest distances from S to all N−1 other vertices.

 Input

There are multiple test cases. The first line of input is an integer T(1≤T<35) denoting the number of test cases. For each test case, the first line contains two integers N(2≤N≤200000) and M(0≤M≤20000). The following M lines each contains two distinct integers u,v(1≤u,v≤N) denoting an edge. And S (1≤S≤N) is given on the last line.

 Output

For each of T test cases, print a single line consisting of N−1 space separated integers, denoting shortest distances of the remaining N−1 vertices from S (if a vertex cannot be reached from S, output ``-1" (without quotes) instead) in ascending order of vertex number.

 Sample Input、

 1 2 0 1

 Sample Output

1

 Source

2016 ACM/ICPC Asia Regional Dalian Online

求补图某一点到其它点的最短路,由于补图边的数目比较多,用dij或spfa肯定会T,正解是用了两个set,每一个点只能进入set一次,时间复杂度就降了下来,以后就当个板子用吧

SCU 4444也是考察了补图最短路

#include <bits/stdc++.h>
using namespace std;
const int MAXN = 200005;
const int MAXM = 20000;
const int INF = 0x3f3f3f3f;
typedef long long ll;
int n,m,vis[MAXN];
int dis[MAXN];
set<int>st,ts;
set<int>::iterator it;
int head[MAXN],ip;
void init()
{
    memset(head,-1,sizeof(head));
    ip = 0;
}
struct note
{
    int v,Next;
}edge[MAXM * 4];
void addedge(int u,int v)
{
    edge[ip].v = v;
    edge[ip].Next = head[u];
    head[u] = ip++;
}
void bfs(int s)
{
    st.clear(),ts.clear();
    for(int i = 1; i <= n;i++) {
        if(i != s) st.insert(i);
    }
    queue<int>q;
    q.push(s);
    memset(dis,-1,sizeof(dis));
    dis[s] = 0;
    while(!q.empty()) {
        int u = q.front();
        q.pop();
        for(int i = head[u]; i != -1; i = edge[i].Next) {
            int v = edge[i].v;
            if(st.count(v) == 0) continue;
            st.erase(v),ts.insert(v);
        }
        for(it = st.begin(); it != st.end(); it++) {
            q.push(*it);
            dis[*it] = dis[u] + 1;
        }
        st.swap(ts);
        ts.clear();
    }
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int s;
        scanf("%d %d",&n,&m);
        init();
        for(int i = 0; i < m; i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            addedge(u,v);
            addedge(v,u);
        }
        scanf("%d",&s);
        bfs(s);
        int flag = 0;
        for(int i = 1; i <= n; i++) {
            if(i == s) continue;
            if(flag == 0) {
                printf("%d",dis[i]);
                flag = 1;
            }
            else printf(" %d",dis[i]);
        }
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值