《ACM程序设计》书中题目 V - 22 给书排序

Description

Jim is fond of reading books, and he has so many books that sometimes it's hard for him to manage them. So he is asking for your help to solve this problem.

Only interest in the name, press year and price of the book, Jim wants to get a sorted list of his books, according to the sorting criteria.

Input

The problem consists of multiple test cases.

In the first line of each test case, there's an integer n that specifies the number of books Jim has. n will be a positive integer less than 100. The next n lines give the information of the books in the format Name Year PriceName will be a string consisting of at most 80 characters from alphabet, Year and Price will be positive integers. Then comes the sorting criteria, which could be NameYear or Price.

Your task is to give out the book list in ascending order according to the sorting criteria in non-ascendent order.

Note: That Name is the first criteria, Year is the second, and Price the third. It means that if the sorting criteria is Year and you got two books with the same Year, you'd sort them according to their Name. If they equals again, according to their Price. No two books will be same in all the three parameters.

Input will be terminated by a case with n = 0.

Output

For each test case, output the book list, each book in a line. In each line you should output in the format Name Year Price, the three parameters should be seperated by just ONE space.

You should output a blank line between two test cases.

Sample Input

3
LearningGNUEmacs 2003 68
TheC++StandardLibrary 2002 108
ArtificialIntelligence 2005 75
Year
4
GhostStory 2001 1
WuXiaStory 2000 2
SFStory 1999 10
WeekEnd 1998 5
Price
0

Sample Output

TheC++StandardLibrary 2002 108
LearningGNUEmacs 2003 68
ArtificialIntelligence 2005 75

GhostStory 2001 1
WuXiaStory 2000 2
WeekEnd 1998 5
SFStory 1999 10


    这到题的基本题意为给你n本书(包括书名,年份,价格),然后再给出一个排序标准,先根据排序标准排,如果相同的话再按排序书名、年份、价格这个顺序给书排列。


源代码如下:

#include<bits/stdc++.h>
using namespace std;
struct book
{ string a;
  int b,c;
}s[101],p;
int main()
{
int n,i,j,k=0;
string m;
while(cin>>n&&n!=0)
{ ++k;
 for(i=0;i<n;++i)
  cin>>s[i].a>>s[i].b>>s[i].c;
 cin>>m;
 if(m=="Name") 
   for(i=0;i<n-1;++i)
    for(j=i+1;j<n;++j)
     if(s[i].a>s[j].a||s[i].a==s[j].a&&s[i].b>s[j].b||s[i].a==s[j].a&&s[i].b==s[j].b&&s[i].c>s[j].c)
     { p=s[i];
       s[i]=s[j];
       s[j]=p;
 }
 if(m=="Year") 
   for(i=0;i<n-1;++i)
    for(j=i+1;j<n;++j)
     if(s[i].b>s[j].b||s[i].b==s[j].b&&s[i].a>s[j].a||s[i].b==s[j].b&&s[i].a==s[j].a&&s[i].c>s[j].c)
     { p=s[i];
       s[i]=s[j];
       s[j]=p;
 }
 if(m=="Price") 
   for(i=0;i<n-1;++i)
    for(j=i+1;j<n;++j)
     if(s[i].c>s[j].c||s[i].c==s[j].c&&s[i].a>s[j].a||s[i].c==s[j].c&&s[i].a==s[j].a&&s[i].b>s[j].b)
     { p=s[i];
       s[i]=s[j];
       s[j]=p;
 }
  if(k>1)cout<<endl;
 for(i=0;i<n;++i)
  cout<<s[i].a<<" "<<s[i].b<<" "<<s[i].c<<endl;
}


     这道题需要注意的地方在于输出格式,两组数据之间有空行,而最后一组数据结束后没有空行。



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值