1001. A+B Format (20)

题目:

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input
-1000000 9
Sample Output
-999,991

题解:

需要注意以下几点:

1.0的特殊处理;

2.将sum3位一组放到数组中后,除首位置可直接输出外,其余都需要用%03d的形式补充0.


代码:

#include <cstdio>
#include <iostream>
using namespace std;
int main()
{
	int a, b, sum;
	scanf("%d%d", &a, &b);
	sum = a + b;
	if(sum == 0)
	{
		printf("0");
		return 0;
	} 
	if(sum < 0)		//把sum转换成整数 
	{
		printf("-");
		sum = -sum;
	}
	int ans[10], k = 0;
	while(sum)
	{
		ans[k++] = sum % 1000;
		sum /= 1000;
	}
	printf("%d", ans[k-1]);
	for(int i = k - 2; i >= 0; i--)
		printf(",%03d", ans[i]);

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值