1013. Battle Over Cities (25)

题目:

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input
3 2 3
1 2
1 3
1 2 3
Sample Output
1
0
0


题解:

统计连通分量的个数。这里DFS和BFS都尝试了一下,DFS全部AC,BFS最后一组数据TLE。一开始我以为是BFS复杂度较高的原因,可是当用邻接矩阵表示时,DFS和BFS都是O(n^2)的复杂度。然后我把STL的queue模板关掉,换成自己用数组模拟队列,这时候就过了,而且和DFS时间相当。经过查阅资料,发现在不开O2优化的情况下,STL的速度很不理想,看来只能把锅甩给编译器啦。

代码:

#include <cstdio>
#include <cstring>
//#include <queue>
//using namespace std;
int n, m, k, a, b, c;
int city[1010][1010];
int visit[1010];
int queue[2020];
void dfs(int x)
{
	visit[x] = 1;
	for(int i = 1; i <= n; i++)
		if(city[x][i] == 1 && visit[i] == 0)
			dfs(i);
	return ;
}
void bfs(int x)
{
//	queue<int> q;
//	q.push(x);
	int front = 0, rear = 0;
	queue[rear++] = x;
	while(front != rear)
	{
		x = queue[front++];
		visit[x] = 1;
		for(int i = 1; i <= n; i++)
			if(city[x][i] == 1 && visit[i] == 0)
				queue[rear++] = i;
	}
	
	return ;
}
int main()
{
//	freopen("a.txt", "r", stdin);
	memset(city, 0, 1010 * 1010 * sizeof(int));
	
	scanf("%d%d%d", &n, &m, &k);
	for(int i = 1; i <= m; i++)
	{
		scanf("%d%d", &a, &b);
		city[a][b] = city[b][a] = 1;
	}
	
	for(int i = 0; i < k; i++)
	{
		scanf("%d", &c);
		memset(visit, 0, (n + 1) * sizeof(int));
		visit[c] = 1;		
		int cnt = 0;
		for(int i = 1; i <= n; i++)
		{
			if(visit[i] == 0)
			{
				dfs(i);	
				cnt++;			
			}
		}
		printf("%d\n", cnt - 1);
	}
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值