It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.
For example, if we have 3 cities and 2 highways connecting city~1~-city~2~ and city~1~-city~3~. Then if city~1~ is occupied by the enemy, we must have 1 highway repaired, that is the highway city~2~-city~3~.
Input
Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.
Output
For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.
Sample Input
3 2 3
1 2
1 3
1 2 3
Sample Output
1
0
0
思路
给定一个无向图并规定,当删除图中的某个顶点时,将会同时把与之连接的边一起删除。接下来给出k个查询,每个查询给出一个欲删除的顶点编号,求删除该顶点(和与其连接的边)后需要增加多少条边,才能使图变为连通(注:k次均在原图上进行)
添加的最少的路线,就是他们的连通分量数-1
#include "cstdio"
#include "algorithm"
#include "iostream"
using namespace std;
int v[1010][1010];
bool visit[1010];
int n;
void dfs(int node){
visit[node]=true;
for (int i=1;i<=n;i++)
{
if(visit[i]==false&&v[node][i]==1){
dfs(i);
}
}
}
int main(){
int m,k,a,b;
cin>>n>>m>>k;
for(int i=0;i<m;i++){
cin>>a>>b;
v[a][b]=v[b][a]=1;//a b两点连通
}
for (int i=0;i<k;i++)
{
fill(visit,visit+1010,false);//初始化 全部没有查看过
cin>>a;
int cnt = 0;
visit[a] = true;//剔除所有与a相连的边
for(int j = 1; j <= n; j++) {
if(visit[j] == false) {
dfs(j);
cnt++;//计算连通分量数
}
}
cout<<cnt-1<<endl;//连通分量数-1
}
return 0;
}