1013 Battle Over Cities

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1​-city2​ and city1​-city3​. Then if city1​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city2​-city3​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.


Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

题目大意

给你一个无向图,保证初始任意两点可相互抵达。求失去任意一点后,需要至少添加几条路,让剩下的点依旧可以相互抵达


思路

对摧毁的点做标记,判断需要BFS几次才能让所有点被扫描到,结果为BFS扫描次数减一


C/C++ 

#include<bits/stdc++.h>
using namespace std;
vector<int> road[1000];
void findRoad(int now,bool apr[]);
int main()
{
    int N,M,K,a,b;
    cin >> N >> M >> K;
    while (M--){
        cin >> a >> b;
        road[a].push_back(b);
        road[b].push_back(a);
    }
    while (K--){
        bool apr[1000]={false};
        b = 0;
        cin >> a;
        apr[a] = true;
        for(int z=1;z<=N;z++) {
            if(!apr[z]){
                b++;
                findRoad(z,apr);
            }
        }
        cout << b-1 << endl;
    }
    return 0;
}
void findRoad(int now,bool apr[])
{
    if(apr[now]) return;
    apr[now] = true;
    for(int x:road[now]) findRoad(x,apr);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

三块不一样的石头

十分满意,一分打赏~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值