Counting Pixels



Description

Did you know that if you draw a circle that fills the screen on your 1080p high definition display, almost a million pixels are lit? That's a lot of pixels! But do you know exactly how many pixels are lit? Let's find out!

Assume that our display is set on a Cartesian grid where every pixel is a perfect unit square. For example, one pixel occupies the area of a square with corners (0,0) and (1,1). A circle can be drawn by specifying its center in grid coordinates and its radius. On our display, a pixel is lit if any part of is covered by the circle being drawn; pixels whose edge or corner are just touched by the circle, however, are not lit.


Your job is to compute the exact number of pixels that are lit when a circle with a given position and radius is drawn.

Input

The input consists of several test cases, each on a separate line. Each test case consists of three integers, x,y, and r(1x,y,r1,000,000), specifying respectively the center (x,y) and radius of the circle drawn. Input is followed by a single line with x = y = r = 0, which should not be processed.

Output

For each test case, output on a single line the number of pixels that are lit when the specified circle is drawn.

Assume that the entire circle will fit within the area of the display.

Sample Input

1 1 1
5 2 5
0 0 0

Sample Output

4
88

HINT

#include<stdio.h>
#include<math.h>
main()
{
 long long a,b,r;
 while(scanf("%lld%lld%lld",&a,&b,&r)!=EOF){
  if(a==0&&b==0&&r==0) continue;
  long long sum=0;
  double y;
  for(long long i=0;i<r;i++){
   y=sqrt(r*r-i*i);
   sum+=ceil(y);
  }
  printf("%lld\n",4*sum);
 } 
}

题解:

这里要注意r的范围很大,所以程序中多处用long long 类型(切不可遗漏任一处),另注意ceil的用法及其与floor的比对

#include<stdio.h>
#include<math.h>
 
intmain( void )
{
double  number=123.54;
double  down,up;
down= floor (number);
up= ceil (number);
printf ( "originalnumber%5.2lf\n" ,number);
printf ( "numberroundeddown%5.2lf\n" ,down);
printf ( "numberroundedup%5.2lf\n" ,up);
 
return0;
}
运行结果:

1
2
3
originalnumber123.54
numberroundeddown123.00
numberroundedup124.00
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值