URL(字符串)

描述:

WHU ACM Team is working on a brand new web browser named "Whu-Super-Browser". You're in response for a powerful feature: recording the previous addresses. Moreover, when a string is inputted, the browser will display all the addresses start with it. The addresses shall be sorted by visited times, in descending order. This feature is very useful to users. Can you complete it? 

There're two kinds of operations: 
Visit [url_str] : visit a website with the URL: [url_str]. 
Display [str] : display all addresses start with [str] and sort them by visited times, in descending order. If two addresses  
have the same visited times, then sort them in the lexicographical order.


输入:

The input consists of multiple test cases. The first line of input contains an integer T, which is the number of test cases. 

Each test case is on several lines. The first line of each test case consists of an integer N. Each of the following N lines consists of an operation, Visit or Display. 

[Technical Specification] 
T is an integer, and T <= 10. 
N is an integer, and 1 <= N <=100. 
There's NO blank line between test cases. 
[url_str] and [str] only contains lower case letters 'a' - 'z', '.', '/', ':'. 
The length of [url_str] and [str] is greater than 0 and won't exceed 100.


输出:

For each test case, display addresses as required, each address on a separated line. Add a blank line after each 'Display' operation.


样例输入:

1
10
Visit http://acm.whu.edu.cn
Visit http://acm.pku.edu.cn
Visit http://acm.timus.ru
Visit http://acm.whu.edu.cn
Visit http://acm.whu.edu.cn
Visit http://acm.pku.edu.cn
Display http://acm
Visit baidu.com
Visit www.whu.edu.cn
Display b


样例输出:

http://acm.whu.edu.cn
http://acm.pku.edu.cn
http://acm.timus.ru

baidu.com



题目大意:

访问网址有两种访问第一种是visit访问需要打网址全名另一种是display访问不需要打网址全称它自动会匹配此前输入过的网址按频率高到低输出如果频率一样根据字典数从小到大输出。每一个display后面需要输出而且输出完后要接空行。



#include<stdio.h>
#include<string.h>
#include<string>
#include<iostream>
#include<algorithm>
using namespace std;
int e;
struct asd
{
	string str;
	int n;
}gw[105];
bool cmp(asd A,asd B)
{
	if(A.n==B.n)								
	return	A.str<B.str;
	else
	return A.n>B.n;
}
void check(string str3)
{
	sort(gw,gw+e,cmp);
	int flag=0;
	for(int i=0;i<e;i++)							//此前出现过的话则将访问量加一					
	{
		if(gw[i].str==str3)
		{
			gw[i].n++;
			flag=1;
			break;
		}
	}
	if(flag==0)										//如果没出现的话将这个网址新加进去 
	{
		gw[e].str=str3;
		gw[e++].n=1;
	}
}
void compare1(string str3)
{
	int len=str3.length();
	for(int i=0;i<e;i++)
	{
		if(gw[i].str.substr(0,len)==str3)			//比较记录下来的网址中前len个字符与str3字符串相同的网址 
		cout<<gw[i].str<<endl;
	}
}
int main()
{
	int t,n;
	string str1;
	string str2;
	scanf("%d",&t);
	while(t--)
	{
		e=0;
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		{
			cin>>str1;
			if(str1=="Visit")                          //判断访问网址的方式 
			{
				cin>>str2;
				check(str2);							//检查输入的网址之前有没有出现 
			}
			else
			{
				sort(gw,gw+e,cmp);						//这个sort不能忘,忘掉的话可能会少数据 (一开始忘写一直wa) 
				cin>>str2;
				compare1(str2);
				printf("\n");
			}
		} 
	}
	return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值