hdu 4763 Theme Section

  
It's time for music! A lot of popular musicians are invited to join us in the music festival. Each of them will play one of their representative songs. To make the programs more interesting and challenging, the hosts are going to add some constraints to the rhythm of the songs, i.e., each song is required to have a 'theme section'. The theme section shall be played at the beginning, the middle, and the end of each song. More specifically, given a theme section E, the song will be in the format of 'EAEBE', where section A and section B could have arbitrary number of notes. Note that there are 26 types of notes, denoted by lower case letters 'a' - 'z'. 

To get well prepared for the festival, the hosts want to know the maximum possible length of the theme section of each song. Can you help us? 
Input
The integer N in the first line denotes the total number of songs in the festival. Each of the following N lines consists of one string, indicating the notes of the i-th (1 <= i <= N) song. The length of the string will not exceed 10^6.
Output
There will be N lines in the output, where the i-th line denotes the maximum possible length of the theme section of the i-th song. 
Sample Input
5
xy
abc
aaa
aaaaba
aaxoaaaaa

Sample Output

0

0

1

1

2

题意:给出一个字符串,在字符串中寻找前后缀相同以及中间也有该相同部分的最大长度。

解题思路:

 kmp水题一道,运用next数组从后往前跳跃,每次判断next[i]*3是否大于字符串长度,杜宇终止循环,输出即可。这一题数据太水,数据中都没有 abcdefgab 这种情况,正确输出是0,还有aaaaaaaaa这种情况,正确输出是 3,这样连续的字符串,输入样例中有一个aaa,也就这一个这样的数据。

代码:代码是试数据时间改的一个代码,能交过,但有问题。

 

#include<stdio.h>
#include<string.h>
char a[1000010];
int next[1000010];
int  len,v;
void fun(void)
{
	int j = 0 ;
	int i = 1 ;
	while( i < len )
	{
		if(j == 0 && a[i] != a[j])
		{
		   next[i] = 0;
		   i++;
			 }
		else if(j > 0 && a[i] != a[j])
		    j=next[j-1];
		else
		  {
		    next[i] = j + 1;
			i++;j++;	
			}  
	}
	int k;
    if(!next[len-1]){//这里的判断情况涵盖不全,上面说的abcdefgab这种情况卡不住,                      应该控制跳的次数,只要不是一次跳到头位置,就说明中间存在和头部尾部相同的部分。
    	printf("0\n");
    	return ;
	}
	k=len-1;v=0;
	while(next[k]>0)
	 {
         if(next[k]*3<=len)
           {
           	 printf("%d\n",next[k]);
           	 break;
		   }
         k=next[k-1];
	 }
}
int main()
{
	int i,j,k,m,n,t;
	m=1;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%s",a);
		len=strlen(a);
		fun(); 
		m++;
	}
	return 0;
}
   
   

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值