Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 9171 | Accepted: 4055 |
Description
This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.
An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are the H-numbers. For this problem we pretend that these are the only numbers. The H-numbers are closed under multiplication.
As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit, and is the product of two H-numbers in only one way: 1 × h. The rest of the numbers are H-composite.
For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.
Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different. In the example above, all five numbers are H-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it's the product of three H-primes.
Input
Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.
Output
For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.
Sample Input
21 85 789 0
Sample Output
21 0 85 5 789 62
大体意思就是求0~n中H-semi-primes(后称h数)的个数 h数能被分解为两个4n+1数相乘的形式 而且这两个数不能再分解为两个4n+1相乘的形式 例如625 = 25*25 = 5*125 显然都不符合题目要求
思路就是筛选法 类比欧拉筛 但 比欧拉筛 但有点不同于欧拉筛
ACcode
#include <iostream>
#include <cstring>
#include <string>
using namespace std;
const int maxn = 1000100;
int num[maxn];
int H_prime[maxn];
void reset()
{
int i,j,k;
memset(num,0,sizeof(num));
for(i=5; i<=maxn/5; i+=4)
{
for(j=5; i*j<=maxn; j+=4)
{
if(num[i]==0 && num[j]==0) ///只有 i j 都可以做因子的时候才可以进行筛选
{
num[i*j] = 1; ///1代表i*j是一个h数
}
else
{
num[i*j] = -1; ///如果出现这种情况 说明i j有至少一个不可以作为因子 比如25 125 但其i||j本身是一个h数 那么i*j就不可以作为因子也不是h数
}
}
}
int sum = 0;
for(i=5; i<=maxn; i++)
{
if(num[i] == 1)
{
sum++;
}
H_prime[i] = sum; ///累加
}
}
int main()
{
int n;
reset();
while(cin>>n && n)
{
cout<<n<<" "<<H_prime[n]<<endl;
}
return 0;
}
/// num[i*j] = -1 这一步很关键 例如 5*81 = 405 -> 1;81*5 = 405 -> -1;;;所以num[405]最后为-1 不是h数 81 = 9*9; 405 = 9*9*5;
类比欧拉筛
http://blog.csdn.net/gentle_guan/article/details/52054986