#1133. Splitting A Linked List【链表】

原题链接

Problem Description:

Given a singly linked list, you are supposed to rearrange its elements so that all the negative values appear before all of the non-negatives, and all the values in [ 0 , K ] [0, K] [0,K] appear before all those greater than K K K. The order of the elements inside each class must not be changed. For example, given the list being 18→7→-4→0→5→-6→10→11→-2 and K K K being 10, you must output -4→-6→-2→7→0→5→10→18→11.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N N N ( ≤ 1 0 5 \leq 10^5 105) which is the total number of nodes, and a positive K K K ( ≤ 1 0 3 \leq 10^3 103). The address of a node is a 5-digit nonnegative integer, and NULL is represented by − 1 −1 1.

Then N N N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer in [ − 1 0 5 , 1 0 5 ] [−10^5 ,10^5] [105,105], and Next is the position of the next node. It is guaranteed that the list is not empty.

Output Specification:

For each case, output in order (from beginning to the end of the list) the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 9 10
23333 10 27777
00000 0 99999
00100 18 12309
68237 -6 23333
33218 -4 00000
48652 -2 -1
99999 5 68237
27777 11 48652
12309 7 33218

Sample Output:

33218 -4 68237
68237 -6 48652
48652 -2 12309
12309 7 00000
00000 0 99999
99999 5 23333
23333 10 00100
00100 18 27777
27777 11 -1

Problem Analysis:

开三个数组分别存储三段满足不同条件的数。详细细节见代码。

Code

#include <iostream>
#include <algorithm>
#include <cstring>
#include <vector>

using namespace std;

const int N = 1e5 + 10;

int h, n, k;
int e[N], ne[N];

int main()
{
    cin >> h >> n >> k;

    for (int i = 0; i < n; i ++ )
    {
        int address, next, data;
        scanf("%d%d%d", &address, &data, &next);
        e[address] = data, ne[address] = next;
    }

    vector<int> a, b, c; // a存负数,b存 [0, k] , c存剩余
    for (int i = h; ~i; i = ne[i])
    {
        int v = e[i];
        if (v < 0) a.push_back(i);
        else if (v <= k) b.push_back(i);
        else c.push_back(i);
    }

    a.insert(a.end(), b.begin(), b.end());
    a.insert(a.end(), c.begin(), c.end());

    for (int i = 0; i < a.size(); i ++ )
    {
        printf("%05d %d ", a[i], e[a[i]]);
        if (i == a.size() - 1) puts("-1");
        else printf("%05d\n", a[i + 1]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值