1025. 复数相加

一个复数类,运算符重载 + ,实现复数和复数的相加。输入一组复数,每行一个复数,直到输入0结束。 输出这组复数的结果。
要求输出符合书写习惯。
输入示例
3+2i
2+3i
0
输出示例

5+5i


时间限制
1000 ms
内存限制
65536 kB
代码长度限制
8192 B
判题程序
Standard
来源
重载


#include<iostream>
using namespace std;
class test
{
  int a;
  int b;
  public:
    test(int a,int b):a(a),b(b){
    }
    test operator + (test& p);
    void out();
};
void test::out()
{
  if(b==0)
  {
    cout<<a;
    return;
  }
  if(a!=0)
    cout<<a;
  if(b<0&&b!=-1)
  {
    cout<<b<<"i";
    return;
  }
  if(b==-1)
  {
    cout<<"-i";
    return;
  }
  if(b==1)
  {
    if(a!=0)
      cout<<"+";
    cout<<"i";
    return;
  }
  if(b>0)
  {
    if(a!=0)
      cout<<"+";
    cout<<b<<"i";
    return;
  }
  
}
test test::operator +(test & p)
{
  a=a+p.a;
  b=b+p.b;
  return *this;
}
int main()
{
  int a,b;
  char c;
  test t(0,0);
  cin>>a;
  while((c=getchar())!='\n')
  {  
    cin>>b;
    getchar();
    if(c=='-')
      b=-b;
    test s(a,b);
    t=t+s;//cout<<c<<endl;
    cin>>a;
  }
  t.out();
  return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值