poj1017(Packets)

Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.

Sample Input

0 0 4 0 0 1 
7 5 1 0 0 0 
0 0 0 0 0 0 

Sample Output

2 
1 

装箱问题,不难写,就是写起来很麻烦,看了大牛的博客后才把代码减短到这么少的。。。详细题解见注释

#include <iostream>
#include <sstream>
#include <fstream>
#include <string>
#include <map>
#include <vector>
#include <list>
#include <set>
#include <stack>
#include <queue>
#include <deque>
#include <algorithm>
#include <functional>
#include <iomanip>
#include <limits>
#include <new>
#include <utility>
#include <iterator>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cctype>
#include <cmath>
#include <ctime>
using namespace std;
typedef long long LL;
const int INF = 0x3f3f3f3f;
const double PI = acos(-1.0);
const double EPS = 1e-8;
const int MAXN = 50010;
int dx[] = {0, 1, 0, -1}, dy[] = {-1, 0, 1, 0};

int main()
{
    int a, b, c, d, e, f, u[] = {0, 5, 3, 1};//u表示3*3盒子分别为4倍数+0、+1、+2、+3时多出的2*2个数
    while (1)
    {
        scanf("%d%d%d%d%d%d", &a, &b, &c, &d, &e, &f);
        if (!a && !b && !c && !d && !e && !f)
            break;
        int ans = d + e + f + (c + 3) / 4;//装3*3、4*4、5*5、6*6需要箱子数
        int y = 5 * d + u[c%4];//装完3*3、4*4多出的2*2个数
        ans += (max(b-y, 0) + 8) / 9;//多出的2*2盒子需要的箱子数
        int x = 36 * ans - 36 * f - 25 * e - 16 * d - 9 * c - 4 * b;//多出的1*1个数
        ans += (max(a-x, 0) + 35) / 36;//多出的1*1盒子需要的箱子数
        cout << ans << endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

算法码上来

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值