约瑟夫问题

约瑟夫问题

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

n个人想玩残酷的死亡游戏,游戏规则如下:

n个人进行编号,分别从1到n,排成一个圈,顺时针从1开始数到m,数到m的人被杀,剩下的人继续游戏,活到最后的一个人是胜利者。

请输出最后一个人的编号。

输入

输入n和m值。

输出

输出胜利者的编号。

示例输入

5 3

示例输出

4
#include<stdio.h>
#include<malloc.h>
struct node
{
    int data;
    struct node *next;
};
struct node * circularlist(int number)
{
    struct node *head,*tail,*p;
    head=(struct node*)malloc(sizeof(struct node));
    head->data=1;
    tail=head;
    for(int i=1;i<number;i++)
    {
        p=(struct node*)malloc(sizeof(struct node));
        p->data=i+1;
        p->next=NULL;
        tail->next=p;
        tail=p;
    }
    tail->next=head;
    return head;
};
void joseph(struct node *head,int number)
{
    struct node *p,*q;
    p=head;
    q=p;
    while(q->next!=head)
        q=q->next;
    while(p->next!=p)
    {
        for(int i=0;i<number-1;i++)
        {
            p=p->next;
            q=q->next;
        }
        q->next=p->next;
        free(p);
        p=q->next;
    }
    printf("%d\n",p->data);
}

int main()
{
    int n,m;
    struct node* head;
    scanf("%d%d",&n,&m);
    head=circularlist(n);
    joseph(head,m);
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值