最大连续子数和

https://www.cnblogs.com/conw/p/5896155.html

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 273975    Accepted Submission(s): 65081


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
 
     
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
 
     
Case 1: 14 1 4 Case 2: 7 1 6
 

Author
Ignatius.L
 

Recommend
We have carefully selected several similar problems for you:   1176  1087  1069  2084  1058 

#include <stdio.h>

//N是数组长度,num是待计算的数组,放在全局区是因为可以开很大的数组
int N, num[100005],M;
int left,right,i,j;//left是左下标,right是右下标

int main()
{
    //输入数据
    scanf("%d",&M);
    for(j=1;j<=M;j++)
    {
    scanf("%d", &N);
    for(i = 1; i <= N; i++)
        scanf("%d", &num[i]);

    num[0] = 0;
    int ans = num[1];
    right=1;
    for(i = 1; i <= N; i++) {
        if(num[i - 1] > 0){
             num[i] += num[i - 1];
        }
        if(num[i] > ans) {
            ans = num[i];
            right=i;            //只标记最右端的下标
        }
    }
    for(i=right-1;i>=1;i--)
    {    
        if(num[i]<0)break;      //如果左端的数是正数,那么一定是连续的,反之是断了的
    }
    left=i+1;
    printf("Case %d:\n%d %d %d\n",j, ans,left,right);
    if(j!=M)printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值