UVA-1588 Kickdown

A research laboratory of a world-leading automobile company has received an order to create a specialtransmission mechanism, which allows for incredibly efficient kickdown — an operation of switching tolower gear. After several months of research engineers found that the most efficient solution requiresspecial gears with teeth and cavities placed non-uniformly. They calculated the optimal flanks of thegears. Now they want to perform some experiments to prove their findings.

The first phase of the experiment is done with planar toothed sections, not round-shaped gears. Asection of length n consists of n units. The unit is either a cavity of height h or a tooth of height 2h.Two sections are required for the experiment: one to emulate master gear (with teeth at the bottom)and one for the driven gear (with teeth at the top).

There is a long stripe of width 3h in the laboratory and its length is enough for cutting two engagedsections together. The sections are irregular but they may still be put together if shifted along eachother.

The stripe is made of an expensive alloy, so the engineers want to use as little of it as possible. Youneed to find the minimal length of the stripe which is enough for cutting both sections simultaneously.

Input

The input file contains several test cases, each of them as described below.
There are two lines in the input, each contains a string to describe a section. The first line describes

master section (teeth at the bottom) and the second line describes driven section (teeth at the top).Each character in a string represents one section unit — 1 for a cavity and 2 for a tooth. The sectionscan not be flipped or rotated.

Each string is non-empty and its length does not exceed 100.

Output

For each test case, write to the output a line containing a single integer number — the minimal lengthof the stripe required to cut off given sections.

Sample Input

2112112112
2212112
12121212
21212121
2211221122
21212

Sample Output

10815 


心路历程(解题思路):这个题其实就是上下两个数字加起来不能超过三(我把没有的一段都看作零),求这个的最短距离,我是将上面的往后移动进行判断,如果不满足就继续往后移,直到满足。一开始没考虑全面,以为只移动上面就可以了,结果发现有的时候移动下面的距离更短,那就将相同的过程再对下面跑一遍。为了简便一些我还定义了求最大最小的函数。

其实感觉代码写得十分臃肿,日后有机会再完善一下。

#include<stdio.h>
#include<string.h>
int min(int a ,int b)
{
    if(a > b)
        return b;
    else
        return a;
}
int max(int a, int b)
{
    if(a > b)
        return a;
    else
        return b;
}
int main()
{
    char x[210], y[210];
    int i, j, k, sum1, len1, len2, l, sum2;
    while(scanf("%s %s", x, y)!=EOF)
    {
        sum1 = 0;
        sum2 = 0;
        len1 = strlen(x);
        len2 = strlen(y);
        for(i = len1; i < (len1 + len2); i++)
            x[i] = '0';
        for(i = len2; i < (len1 + len2); i++)
            y[i] = '0';
        for(l = 0; l <= len2; l++)
        {
            k = 1;
            for(j = 0; j < max(len1, len2 - l); j++)
            {
                if(y[l + j] + x[j] - 2 * '0' > 3)
                {
                    k = 0;
                    break;
                }
            }
            if(k == 1)
            {
                sum1 = l + j;
                break;
            }
        }
        for(l = 0; l <= len1; l++)
        {
            k = 1;
            for(j = 0; j < max(len1 - l, len2); j++)
            {
                if(y[j] + x[j + l] - 2 * '0' > 3)
                {
                    k = 0;
                    break;
                }
            }
            if(k == 1)
            {
                sum2 = l + j;
                break;
            }
        }
        printf("%d\n", min(sum1, sum2));
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值