UVA - 1588 Kickdown(模拟)

A research laboratory of a world-leading automobile company has received an order to create a special transmission mechanism, which allows for incredibly efficient kickdown — an operation of switching to lower gear. After several months of research engineers found that the most efficient solution requires special gears with teeth and cavities placed non-uniformly. They calculated the optimal flanks of the gears. Now they want to perform some experiments to prove their findings. The first phase of the experiment is done with planar toothed sections, not round-shaped gears. A section of length n consists of n units. The unit is either a cavity of height h or a tooth of height 2h. Two sections are required for the experiment: one to emulate master gear (with teeth at the bottom) and one for the driven gear (with teeth at the top).
There is a long stripe of width 3h in the laboratory and its length is enough for cutting two engaged sections together. The sections are irregular but they may still be put together if shifted along each other.
The stripe is made of an expensive alloy, so the engineers want to use as little of it as possible. You need to find the minimal length of the stripe which is enough for cutting both sections simultaneously.
Input
The input file contains several test cases, each of them as described below. There are two lines in the input, each contains a string to describe a section. The first line describes master section (teeth at the bottom) and the second line describes driven section (teeth at the top). Each character in a string represents one section unit — 1 for a cavity and 2 for a tooth. The sections can not be flipped or rotated. Each string is non-empty and its length does not exceed 100.
Output
For each test case, write to the output a line containing a single integer number — the minimal length of the stripe required to cut off given sections.
Sample Input
2112112112 2212112 12121212 21212121 2211221122 21212
Sample Output
10 8 15
一道紫书上的课后习题,我们可以先让两个字符串自左对齐
第一种情况:让第一个字符串向右移动,找到符合条件的情况后break;
第二种情况:让第二个字符串向左移动,找到符合条件的情况后break;
code:

#include<bits/stdc++.h>
using namespace std;
#define INF 0x3f3f3f3f
const int N = 300;
int main()
{
    ios::sync_with_stdio(false);
    string s1,s2;
    while(cin>>s1>>s2)
    {
        int mi=s1.size()+s2.size();
        for(int i=0;i<s1.size();i++)
        {
            int k=i,j;
            int pp=0;
            for(j=0;j<s2.size();j++)
            {
                if((int)(s1[k]-'0')+(int)(s2[j]-'0')<=3)
                {
                    k++;
                    if(k==s1.size())
                        {mi=min(mi,(int)(s2.size()+i));pp=1;break;}
                    else if(j==s2.size()-1)
                        {mi=min(mi,(int)(s1.size()));pp=1;break;}
                }
                else
                    break;
            }
            if(pp   )
                break;
        }
        for(int i=0;i<s2.size();i++)
        {
            int k=i;
            int pp=0;
            for(int j=0;j<s1.size();j++)
            {
                if((int)(s1[j]-'0')+(int)(s2[k]-'0')<=3)
                {
                    k++;
                    if(k==s2.size())
                        {mi=min(mi,(int)(s1.size()+i));pp=1;break;}
                    else if(j==s1.size()-1)
                        {mi=min(mi,(int)(s2.size()));pp=1;break;}
                }
                else
                    break;
            }
            if(pp)
                break;
        }
        cout<<mi<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值