Apple Catching POJ - 2385

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds. 

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples). 

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.
Input
* Line 1: Two space separated integers: T and W 

* Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.
Output
* Line 1: The maximum number of apples Bessie can catch without walking more than W times.
Sample Input
7 2
2
1
1
2
2
1
1
Sample Output
6
Hint
INPUT DETAILS: 

Seven apples fall - one from tree 2, then two in a row from tree 1, then two in a row from tree 2, then two in a row from tree 1. Bessie is willing to walk from one tree to the other twice. 

OUTPUT DETAILS: 

Bessie can catch six apples by staying under tree 1 until the first two have dropped, then moving to tree 2 for the next two, then returning back to tree 1 for the final two.

思路:很经典的一道dp,但是刚开始学dp,所以做的时候在边界的问题上处理的不是很好,但是很幸运的一次就过了。说说我的思路,我是用了一个三位数组,dp[x][y][z]来储存数据,其中x代表时间,y代表精力,z代表在哪一课树下。氛围两种情况讨论,那就是在当前的时间和树下会落下苹果,与不会落下苹果两种情况讨论。然后再进行移动操作。

#include<iostream>
#include<algorithm>
#include<cstring>
#include <string>
#include <set>
#include <queue>
#include <cmath>
#include <iomanip>
#include <vector>
#include <cstdio>
#define MAXN 1010

using namespace std;

int main() {
    int n, m;
    while (cin >> n >> m) {
        int tree[MAXN];
        int x;
        for (int i = 1; i <= n; ++i) {
            cin >> x;
            tree[i] = x;
        }
        int dp[MAXN][MAXN / 10][5] = {0};
        if (tree[1] == 1)
            dp[1][0][1] = 1;
        else
            dp[1][0][2] = 1;
        int max_num = 0;
        for (int i = 1; i <= n; ++i) {
            for (int j = 0; j <= m; ++j) {
                for (int k = 1; k <= 2; ++k) {
                    if (k == tree[i]) {
                        // 这里是求当前这个节点的最大值
                        dp[i][j][k] = max(dp[i][j][k], dp[i - 1][j][k] + 1); 
                        dp[i][j + 1][3 - k] = max(dp[i][j][k], dp[i][j + 1][3 - k]);
                        // 这里我们进行一个移动的操作,可以模拟接完当前节点的苹果立刻去另一棵树
                    }
                    else {
                        dp[i][j][k] = max(dp[i][j][k], dp[i - 1][j][k]);
                        dp[i][j + 1][3 - k] = max(dp[i][j][k], dp[i][j + 1][3 - k] + 1);
                    }
                    max_num = max(max_num, dp[i][j][k]);
                }
            }
        }
        cout << max_num << endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值