HDU 4135(基本的容斥定理)

              

                                Co-prime

     
Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N.
Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.


Input

The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 10 15) and (1 <=N <= 10 9).

Output


For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.


Sample Input


2
1 10 2
3 15 5

Sample Output


Case #1: 5
Case #2: 10

题意:给定a、b、c,求a到b区间内与c互质的数。

思路:

通常我们求1~n中与n互质的数的个数都是用欧拉函数! 但如果n比较大或者是求1~m中与n互质的数的个数等等问题, 要想时间效率高的话还是用容斥原理!

容斥、先对n分解质因数,分别记录每个质因数, 那么所求区间内与某个质因数不互质的个数就是n / r(i),假设r(i)是r的某个质因子 假设只有三个质因子, 总的不互质的个数应该为p1+p2+p3-p1*p2-p1*p3-p2*p3+p1*p2*p3, 及容斥原理,可以转向百度百科查看相关内容 pi代表n/r(i),即与某个质因子不互质的数的个数 ,当有更多个质因子的时候, 可以用状态压缩解决,二进制位上是1表示这个质因子被取进去了。 如果有奇数个1,就相加,反之则相减.

#include<cstdio>
#include<iostream>
#include<vector>
using namespace std;
vector<int>x;
void divide(int n)///素因子的分解
{
    x.clear();
    for(int i=2;i*i<=n;i++)
        if(n%i==0)
    {
        x.push_back(i);
        while(n%i==0)
        {
            n/=i;
        }
    }
    if(n!=1)
        x.push_back(n);
}
long long solve(long long b,long long n)
{
    long long sum=0;
    for(int i=1;i<(1<<x.size());i++)///用二进制数1,0来表示第几个素因子是否被用到
    {                ///三个因子是2,3,5,则i=3时二进制是011,表示第2、3个因子被用到
         long long cnt=0,val=1;
        for(int j=0;j<x.size();j++)
          if(i&(1<<j))///i的第j位是否有素因子存在
          {
              val*=x[j];
              cnt++;
          }
          if(cnt&1)///容斥原理 奇加偶减
            sum+=b/val;
          else
            sum-=b/val;
    }
    return b-sum;
}
int main()
{
    int t;
    cin>>t;
    long long a,b,n;
    for(int i=1;i<=t;i++)
    {
        cin>>a>>b>>n;
        if(n==0)
        {
            cout<<"Case #"<<i<<": "<<0<<endl;
            continue;
        }
        divide(n);
        cout<<"Case #"<<i<<": "<<solve(b,n)-solve(a-1,n)<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值