hdu1145.So you want to be a 2^n-aire?

6 篇文章 0 订阅

 http://acm.hdu.edu.cn/showproblem.php?pid=1145

So you want to be a 2n-aire?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 94    Accepted Submission(s): 72

Problem Description
The player starts with a prize of $1, and is asked a sequence of n questions. For each question, he may 
quit and keep his prize. 
answer the question. If wrong, he quits with nothing. If correct, the prize is doubled, and he continues with the next question. 
After the last question, he quits with his prize. The player wants to maximize his expected prize. 
Once each question is asked, the player is able to assess the probability p that he will be able to answer it. For each question, we assume that p is a random variable uniformly distributed over the range t .. 1. 
 

 

Input
Input is a number of lines, each with two numbers: an integer 1 ≤ n ≤ 30, and a real 0 ≤ t ≤ 1. Input is terminated by a line containing 0 0. This line should not be processed.
 

 

Output
For each input n and t, print the player's expected prize, if he plays the best strategy. Output should be rounded to three fractional digits.
 

 

Sample Input
1 0.5
1 0.3
2 0.6
24 0.25
0 0
 

 

Sample Output
1.500
1.357
2.560
230.138
 

 

Source

 

题意:
一开始有1美元,有一个游戏,每回合可以选择领当前金钱退出游戏,或者选择继续游戏,赢了金钱double,否则0美元且游戏终止,赢的概率在[t..1]分布。
大致思路:
其实我自己什么思路都没有。题解是酱紫的——
f[i] 表示n-i轮后到得的最大金钱数。则f[0] = 2 n
对于第i轮,要不放弃得2 i美元,要不有p的机会有f[i - 1]。
因为p分布在[t-1],所以概率密度是1/(1-t), 然后对max(p*f[i], 2 n-i)dp积分。
即f[i] = 1/(1-t)*int^1(max(p*f[i], 2 n-i)dp)   ( int^1(f(x)dx)是对f(x)一重积分。)
其实这个dp方程是还是挺难理解,好像总是有点问题。
代码:
#include <cmath>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

#define MAXN 
#define eps (1e-8)
#define INF 1000000000
#define abs(x) ( (x) > 0? (x): -(x) )
#define sqr(x) ((x) * (x))
#define MAX(a, b) ((a) > (b)? (a): (b))
#define MIN(a, b) ((a) < (b)? (a): (b))

typedef long long LL;

int n;
double t;

void swap( int &x, int &y ) { int temp = x; x = y; y = temp; }

int main()
{
    while ( scanf( "%d%lf", &n, &t ) != EOF && n )
    {
        double f, g;
        f = (double)( 1 << n );
        for ( int i = 1; i <= n; ++i )
        {
            double p = ( 1 << ( n - i ) ) / f;
            if ( p < t )
                g = ( 1 + t ) / 2 * f;
            else if ( p > 1 )
                g = ( 1 << ( n - i ) );
            else
                g = 1 / ( 1 - t ) * ( ( p - t ) * ( 1 << ( n - i ) ) + ( 1 - sqr(p) ) / 2 * f );
            f = g;
        }
        printf( "%.3lf\n", f );
    }
    return 0;
}


 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值