So you want to be a 2n-aire?[HDU1145]

So you want to be a 2n-aire?
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 408 Accepted Submission(s): 284


Problem Description
The player starts with a prize of $1, and is asked a sequence of n questions. For each question, he may
quit and keep his prize.
answer the question. If wrong, he quits with nothing. If correct, the prize is doubled, and he continues with the next question.
After the last question, he quits with his prize. The player wants to maximize his expected prize.
Once each question is asked, the player is able to assess the probability p that he will be able to answer it. For each question, we assume that p is a random variable uniformly distributed over the range t .. 1.

 

Input
Input is a number of lines, each with two numbers: an integer 1 ≤ n ≤ 30, and a real 0 ≤ t ≤ 1. Input is terminated by a line containing 0 0. This line should not be processed.

 

Output
For each input n and t, print the player's expected prize, if he plays the best strategy. Output should be rounded to three fractional digits.

 

Sample Input
1 0.5
1 0.3
2 0.6
24 0.25
0 0

Sample Output
1.500
1.357
2.560
230.138

 

http://blog.csdn.net/hackerwin7/article/details/38307329

没看懂前一道题和后一道题有什么区别,感觉这题就是生拉硬套的扯淡。

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<iostream>
using namespace std;
double ex[30+5]={0.0};//best expect
double mon[30+5]={0.0};//best money
double t=0.0;//probability p is t < p < 1
int n=0;//number of question
double bp=0.0;//boundary probability, if p > bp then get in the question  otherwise get out the question
int main()
{
    mon[0]=1;//after answer 0 question,the index begin with 1
    for(int i=1;i<=30;i++)
    {
        mon[i]=mon[i-1]*2;
    }
    while(scanf("%d%lf",&n,&t)!=EOF&&(n>0))
    {
        ex[n]=mon[n];
        //from ex[i+1] get the ex[i],ex[0] is our answers
        for(int i=n-1;i>=0;i--)
        {
            bp=mon[i]/ex[i+1];// 2^i/ex[i+1] is the boundary probability ==>  bp * ex[i+1] > 2^i
            if(bp<=t)//bp is not in [t,1) range, all p in [t,1) will let the p * ex[i+1] >2^i
            {
                ex[i]=(1+t)/2 * ex[i+1];
            }
            else// E = p*x + (1-p)*y
            {
                ex[i]=(bp-t)/(1-t) * mon[i] + (1-bp)/(1-t) * (1+bp)/2 * ex[i+1];
            }
        }
        printf("%.3lf\n",ex[0]);
    }
    return(0);
}
View Code

 

转载于:https://www.cnblogs.com/dramstadt/p/6088887.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值