【CUGBACM15级BC第31场 B】hdu 5179 beautiful number

70 篇文章 0 订阅

beautiful number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 851    Accepted Submission(s): 553


Problem Description
Let A=ni=1ai10ni(1ai9) ( n is the number of A 's digits). We call A as “beautiful number” if and only if a[i ]a[i+1] when 1i<n and a[i ] mod a[ j ]=0 when 1in,i<jn (Such as 931 is a "beautiful number" while 87 isn't).
Could you tell me the number of “beautiful number” in the interval [L,R ] (including L and R)?
 

Input
The fist line contains a single integer T (about 100), indicating the number of cases.
Each test case begins with two integers L,R(1LR109) .
 

Output
For each case, output an integer means the number of “beautiful number”.
 

Sample Input
  
  
2 1 11 999999993 999999999
 

Sample Output
  
  
10 2
 
数位dp
#include <cstring>
#include <cstdio>
#include <string.h>
#include <iostream>
using namespace std;

int num[15];
int dp[15][15];
///mark==1没前导0 mark==0有前导0
int dfs(int pos, int pre, int over, int mark)
{
    if (pos < 0)
    {
        return 1;
    }
    if (dp[pos][pre] != -1 && !over)
    {
        return dp[pos][pre];
    }
    int last = over ? num[pos] : 9;
    int ans = 0;
    for (int i = 0; i <= last; i++)
    {
        if (mark == 0 || (pre >= i && i != 0 && pre % i == 0))
        {
            ans += dfs(pos - 1, i, over && i == last, mark || i);
        }
    }
    if (!over)
    {
        dp[pos][pre] = ans;
    }
    return ans;
}
int solve(int n)
{
    int len = 0;
    while (n)
    {
        num[len++] = n % 10;
        n /= 10;
    }
    return dfs(len - 1, 0, true, 0);

}
int main()
{
    int t;
    scanf("%d", &t);
    memset(dp, -1, sizeof(dp));
    while (t--)
    {
        int l, r;
        scanf("%d%d", &l, &r);
        printf("%d\n", solve(r) - solve(l - 1));

    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值