【CUGBACM15级BC第33场 B】hdu 5187 zhx's contest

70 篇文章 0 订阅
34 篇文章 0 订阅

zhx's contest

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3115    Accepted Submission(s): 1003


Problem Description
As one of the most powerful brushes, zhx is required to give his juniors n problems.
zhx thinks the ith problem's difficulty is i . He wants to arrange these problems in a beautiful way.
zhx defines a sequence {ai} beautiful if there is an i that matches two rules below:
1: a1..ai are monotone decreasing or monotone increasing.
2: ai..an are monotone decreasing or monotone increasing.
He wants you to tell him that how many permutations of problems are there if the sequence of the problems' difficulty is beautiful.
zhx knows that the answer may be very huge, and you only need to tell him the answer module p .
 

Input
Multiply test cases(less than 1000 ). Seek EOF as the end of the file.
For each case, there are two integers n and p separated by a space in a line. ( 1n,p1018 )
 

Output
For each test case, output a single line indicating the answer.
 

Sample Input
  
  
2 233 3 5
 

Sample Output
  
  
2 1
Hint
In the first case, both sequence {1, 2} and {2, 1} are legal. In the second case, sequence {1, 2, 3}, {1, 3, 2}, {2, 1, 3}, {2, 3, 1}, {3, 1, 2}, {3, 2, 1} are legal, so the answer is 6 mod 5 = 1
 

思路:由题意可以求出答案为(2^n-2)%p

但是n,p都是LL型的,快速幂的时候会爆LL,所以这里要用到快速乘法,快速乘法其实和快速幂差不多,就是把乘号改为加号

注意:当n为1时,要输出1,而当p为1时要输出0;

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define LL long long
using namespace std;

LL n, p;
LL multi(LL a, LL b)    //快速乘法,其实和快速幂差不多
{
    LL ret = 0;
    while (b)
    {
        if (b & 1)
        {
            ret = (ret + a) % p;
        }
        a = (a + a) % p;
        b >>= 1;
    }
    return ret;
}
LL powmod(LL a, LL b)   //快速幂
{
    LL ret = 1;
    while (b)
    {
        if (b & 1)
        {
            ret = multi(ret, a) % p;
        }
        a = multi(a, a) % p;
        b >>= 1;
    }
    return ret;
}
int main()
{
    while (cin >> n >> p)
    {
        if (p == 1)
        {
            cout << 0 << endl;
        }
        else if (n == 1)
        {
            cout << 1 << endl;
        }
        else
        {
            LL ans = powmod(2, n) - 2;
            if (ans < 0)
            {
                ans += p;
            }
            cout << ans << endl;
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值