HDU 5187 zhx's contest(快速幂+快速乘法)

zhx's contest

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3730    Accepted Submission(s): 1207


 

Problem Description

As one of the most powerful brushes, zhx is required to give his juniors n problems.
zhx thinks the ith problem's difficulty is i. He wants to arrange these problems in a beautiful way.
zhx defines a sequence {ai} beautiful if there is an i that matches two rules below:
1: a1..ai are monotone decreasing or monotone increasing.
2: ai..an are monotone decreasing or monotone increasing.
He wants you to tell him that how many permutations of problems are there if the sequence of the problems' difficulty is beautiful.
zhx knows that the answer may be very huge, and you only need to tell him the answer module p.

 

 

Input

Multiply test cases(less than 1000). Seek EOF as the end of the file.
For each case, there are two integers n and p separated by a space in a line. (1≤n,p≤1018)

 

 

Output

For each test case, output a single line indicating the answer.

 

 

Sample Input

 

2 233 3 5

 

 

Sample Output

 

2 1

Hint

In the first case, both sequence {1, 2} and {2, 1} are legal. In the second case, sequence {1, 2, 3}, {1, 3, 2}, {2, 1, 3}, {2, 3, 1}, {3, 1, 2}, {3, 2, 1} are legal, so the answer is 6 mod 5 = 1

 

 

Source

BestCoder Round #33

 

 

Recommend

hujie   |   We have carefully selected several similar problems for you:  6361 6360 6359 6358 6357 

自己的组合数学。。高中的之后学的就不好。。

 

题意:数字1~n,按某种顺序排列,且满足下列某一个条件:(1)a1~ai递增,ai~an递减(2)a1~ai递减,ai~an递增。问有多少种不同的排列。

ps:看数据范围就知道要用快速幂,不过可惜如果只用快速幂会错,应为n和p的范围都是10^18,快速幂里在还没有模p之前的乘法都有可能超出long long int。所以想到用加法,a*b就是b个a相加,每一步都模p,然后用快速幂的原理不断二分,这就是所谓的快速乘法。

思路:首先是全部递减或全部递增各一种;另外就是满足上列两个条件的情况了,要想满足条件(1)那就只能把最大的n放在i位置,共有C(1,n-1)+C(2,n-1)+。。。+C(n-2,n-1)即2^(n-1)-2;条件(2)与(1)相同,所以共有(2^(n-1)-2)*2+2=2^n-2.

计算。(2^n-2)%p;

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <queue>
#include <stack>
using namespace std;
#define ll long long
ll n,p,res;
ll modmul(ll a,ll b)//快速乘
{
    ll d=0,t=a;
    while(b>0)
    {
        if(b&1) d=(d+t)%p;
        b=b/2;
        t=(t+t)%p;
    }
    return d;
}
ll modxp(ll a,ll b)//快速幂
{
    ll d=1,t=a;
    while(b)
    {
        if(b&1)
            d=modmul(d,t)%p;
        t=modmul(t,t)%p;
        b>>=1;
    }return d;
}
int main()
{
    while(scanf("%I64d%I64d",&n,&p)!=EOF)
    {
        if(n==1)
        {
            printf("%I64d\n",n%p);
            continue;
        }
        res=(modxp(2,n)+p-2)%p;
        printf("%I64d\n",res);
    }return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值