【CUGBACM15级BC第33场 A】hdu 5186 zhx's submissions

70 篇文章 0 订阅

zhx's submissions

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2460    Accepted Submission(s): 717


Problem Description
As one of the most powerful brushes, zhx submits a lot of code on many oj and most of them got AC.
One day, zhx wants to count how many submissions he made on n ojs. He knows that on the ith oj, he made ai submissions. And what you should do is to add them up.
To make the problem more complex, zhx gives you n Bbase numbers and you should also return a Bbase number to him.
What's more, zhx is so naive that he doesn't carry a number while adding. That means, his answer to 5+6 in 10base     is  1 . And he also asked you to calculate in his way.
 

Input
Multiply test cases(less than 1000 ). Seek EOF as the end of the file.
For each test, there are two integers n and B separated by a space. ( 1n100 , 2B36 )
Then come n lines. In each line there is a Bbase number(may contain leading zeros). The digits are from 0 to 9 then from a to z (lowercase). The length of a number will not execeed 200.
 

Output
For each test case, output a single line indicating the answer in Bbase   (no leading zero).
 

Sample Input
  
  
2 3 2 2 1 4 233 3 16 ab bc cd
 

Sample Output
  
  
1 233 14
 

题意:给出n个b进制的数,要求把这n个数加起来,输出也是b进制,不需要进位。

题解:高精度加法题

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
const int N = 205;

int n, b, length[N];
char str1[N], res[N], str[N][N];
int solve(char c)
{
    int temp;
    if (c >= '0' && c <= '9')
    {
        temp = c - '0';
    }
    else
    {
        temp = c + 10 - 'a';
    }
    return temp;
}
int main()
{
    while (scanf("%d%d", &n, &b) != EOF)
    {
        memset(str, '0', sizeof(str));
        int len = 0;
        for (int i = 0; i < n; i++)
        {
            scanf("%s", str1);
            length[i] = strlen(str1);
            for (int j = 0, k = length[i] - 1; k >= 0; k--, j++)
            {
                str[i][j] = str1[k];
            }
            len = max(len, length[i]);
        }
        for (int i = 0; i < len; i++)
        {
            int temp = 0;
            for (int j = 0; j < n; j++)
            {
                char c = str[j][i];
                int temp1 = solve(c);
                temp += temp1;
                temp = temp % b;
            }
            if (temp >= 10)
            {
                res[i] = 'a' + temp - 10;
            }
            else
            {
                res[i] = temp + '0';
            }
        }
        int flag = 1, i = 0;
        for (i = len - 1; i >= 0; i--)
        {
            if (res[i] != '0')
            {
                break;
            }
        }
        if (i == -1)
        {
            flag = 0;
        }
        for (int j = i; j >= 0; j--)
        {
            printf("%c", res[j]);
        }
        if (!flag)
        {
            printf("0");
        }
        printf("\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值