【CUGBACM15级BC第22场 B】hdu 5143 NPY and arithmetic progression

70 篇文章 0 订阅

NPY and arithmetic progression

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1541    Accepted Submission(s): 479


Problem Description
NPY is learning arithmetic progression in his math class. In mathematics, an arithmetic progression (AP) is a sequence of numbers such that the difference between the consecutive terms is constant.(from wikipedia)
He thinks it's easy to understand,and he found a challenging problem from his talented math teacher:
You're given four integers, a1,a2,a3,a4 , which are the numbers of 1,2,3,4 you have.Can you divide these numbers into some Arithmetic Progressions,whose lengths are equal to or greater than 3?(i.e.The number of AP can be one)
Attention: You must use every number exactly once.
Can you solve this problem?
 

Input
The first line contains a integer T — the number of test cases ( 1T100000    ).
The next T lines,each contains 4 integers a1,a2,a3,a4(0a1,a2,a3,a4109) .
 

Output
For each test case,print "Yes"(without quotes) if the numbers can be divided properly,otherwise print "No"(without quotes).
 

Sample Input
  
  
3 1 2 2 1 1 0 0 0 3 0 0 0
 

Sample Output
  
  
Yes No Yes
Hint
In the first case,the numbers can be divided into {1,2,3} and {2,3,4}. In the second case,the numbers can't be divided properly. In the third case,the numbers can be divided into {1,1,1}.
 
题意:1,2,3,4的数量分别为a1,a2,a3,a4,问你能不能把所有的数字组成0~多个长度至少为3的等差数列

思路:可以发现,全部的可能等差序列只有

1,2,3

2,3,4

1,2,3,4

1,1,1....

2,2,2....

3,3,3....

那么,当(1,2,3)这个等差数列的数量大于等于3时,我们假设为k,可以转换为(k个1,k个2,k个3),(2,3,4),(1,2,3,4)同理

因此我们只需要枚举0~2的(1,2,3),(2,3,4),(1,2,3,4),然后判断原序列减去这27种情况里有没有满足条件的(为0或者>=3)即可


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;

int ok(int a[])
{
    if ((a[0] == 0 || a[0] >= 3) && (a[1] == 0 || a[1] >= 3) && (a[2] == 0 || a[2] >= 3) && (a[3] == 0 || a[3] >= 3))
    {
        return 1;
    }
    return 0;
}
int main()
{
    int a[10], b[10];
    int T;
    scanf("%d", &T);
    while (T--)
    {
        for (int i = 0; i < 4; i++)
        {
            scanf("%d", &a[i]);
        }
        int flag = 0;
        if (ok(a))
        {
            flag = 1;
        }
        else
        {
            for (int i = 0; i <= 2; i++)
                for (int j = 0; j <= 2; j++)
                    for (int k = 0; k <= 2; k++)
                    {
                        b[0] = a[0] - i - k;
                        b[1] = a[1] - i - j - k;
                        b[2] = a[2] - i - j - k;
                        b[3] = a[3] - j - k;
                        if (ok(b))
                        {
                            flag = 1;
                        }
                    }
        }
        if (flag)
        {
            printf("Yes\n");
        }
        else
        {
            printf("No\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值