【CUGBACM15级BC第9场 B】hdu 4994 Revenge of Nim

70 篇文章 0 订阅

Revenge of Nim

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 822    Accepted Submission(s): 422


Problem Description
Nim is a mathematical game of strategy in which two players take turns removing objects from distinct heaps. On each turn, a player must remove at least one object, and may remove any number of objects provided they all come from the same heap.
---Wikipedia

Today, Nim takes revenge on you. The rule of the game has changed a little: the player must remove the objects from the current head(first) heap. Only the current head heap is empty can the player start to remove from the new head heap. As usual, the player who takes the last object wins.
 

Input
The first line contains a single integer T, indicating the number of test cases.

Each test case begins with an integer N, indicating the number of heaps. Then N integer Ai follows, indicating the number of each heap successively, and the player must take objects in this order, from the first to the last.

[Technical Specification]
1. 1 <= T <= 100
2. 1 <= N <= 1 000
3. 1 <= Ai <= 1 000 000 000
 

Output
For each test case, output “Yes” if the first player can always win, otherwise “No”.
 

Sample Input
  
  
2 1 2 2 1 1
 

Sample Output
  
  
Yes No
 
题意:
有n 堆石子,从第一堆到最后一堆,每次可以取任意多个,但只能取同一堆的,最后取完的人赢,问先手能否胜利?

思路:

尼姆博奕的变形,应该来说比尼姆博奕要好理解。  这里当某一堆里石头个数为1时,无奈,此人只能把该堆取完。

当某一堆石头个数大于1时,此时此人可以根据后面所有堆是必胜态还是必败态来决定是把该堆取完让下一个人进行那个状态还是把该堆取完只剩一个,让自己进行那个状态。   所以不管后面如何变化,我们只要考虑第一次出现的大于1的堆之前有多少个大小为1的堆即可。因为谁先进入这个第一次出现的大于1的堆即可获得胜利
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define N 1100

int a[N];
int main()
{
    int T, n;
    scanf("%d", &T);
    while (T--)
    {
        scanf("%d", &n);
        int flag = 0, ans = 0;
        for (int i = 1; i <= n; i++)
        {
            scanf("%d", &a[i]);
            if (a[i] > 1)
            {
                flag = 1;
            }
            if (!flag)
            {
                ans++;
            }
        }
        if (!flag)
        {
            if (ans & 1)
            {
                printf("Yes\n");
            }
            else
            {
                printf("No\n");
            }
        }
        else
        {
            if (ans & 1)
            {
                printf("No\n");
            }
            else
            {
                printf("Yes\n");
            }
        }
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值