期望DP——E - A Dangerous LightOJ - 1027

博客目录

返回二级目录——kaugnbin概率dp习题集

一、原题

题目传送门

You are in a maze; seeing n doors in front of you in beginning. You can choose any door you like. The probability for choosing a door is equal for all doors.

If you choose the ith door, it can either take you back to the same position where you begun in xi minutes, or can take you out of the maze after ximinutes. If you come back to the same position, you can't remember anything. So, every time you come to the beginning position, you have no past experience.

Now you want to find the expected time to get out of the maze.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer n (1 ≤ n ≤ 100) denoting the number of doors. The next line contains n space separated integers. If the ithinteger (xi) is positive, you can assume that the ith door will take you out of maze after xi minutes. If it's negative, then the ith door will take you back to the beginning position after abs(xi) minutes. You can safely assume that 1 ≤ abs(xi) ≤ 10000.

Output

For each case, print the case number and the expected time to get out of the maze. If it's impossible to get out of the maze, print 'inf'. Print the result in p/q format. Where p is the numerator of the result and q is the denominator of the result and they are relatively prime. See the samples for details.

Sample Input

3

1

1

2

-10 -3

3

3 -6 -9

Sample Output

Case 1: 1/1

Case 2: inf

Case 3: 18/1

二、题目大意

 

题意:你身在一个迷宫里面,现在在你面前有N个门。每个门要么把你传送出迷宫,要么把你传送到原来的位置且你的记忆也会回到初始的时候(也就是每次尝试相互独立)。现在给出每个门传送的时间t,若t为正数,说明该门花费时间t可以将你传送出迷宫,若 t 为负数,说明该门花费时间 t 将你传送到原来的位置。已知你选择每个门的概率是相同的,问你出迷宫所花费时间的期望。输出结果写出分数形式,且分子分母互质,若不能出迷宫输出inf。

(翻译来自互联网)

三、分析

设ai为可以出去的门的花费,bi为不可以出去的门的花费,sum()为求和函数,e为从迷宫出去的期望(花费),numb为b类门的个数。因为有n个门,又是等概率选的且每次选择相互独立,所以每个门被选择的概率:p=1/n

 

  • 一次可以出去的花费为:sum(ai*p)=p*sum(ai):直接套用概率论的公式:一个事件的期望=每种情况的期望的期望 * 对应的概率
  • 一次不可以出去的花费为:p*sum(bi+e)=p*sum(bi)+numb*e意思是  花费bi+从相同的迷宫出去的花费,进一步解释:即用了一个门之后,又回到了原点,而从原点出去的期望为e,所以总花费是bi+e,而对于每个不能出去的门都有相同的结论,所以直接求和sum(bi+e)。ps:此处e也是所求的期望,此处假设e是已知的。

综上所述,所求的e为:

e=以上两种情况之和=p*sum(ai)+p*sum(bi)+p*numb*e;

移项,将e移到左边。

(1-p*numb)*e=p*[sum(ai)+sum(bi)]

化简得

e=p/(1-p*numb)*[sum(ai)+sum(bi)]

然后p=1/n,代入化简得

e=[sum(ai)+sum(bi)]  / (n-numb)

推导完毕。

然后再特判一下inf就好了。

四、AC代码

仅供参考(第一次写的时候思路不太清楚,变量名写的比较乱,凑合着看吧)

#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
typedef long long ll; 

int main()
{
	int n,T;
	cin>>T;
	int i,t; 
	int sumtc,sumts;//c为可以出去的,s为不可以
	int c,s;
	int cs=1;
	while(T--)
	{
		cin>>n;
		sumtc=sumts=s=c=0;
		for(i=0;i<n;i++)
		{
			scanf("%d",&t);
			if(t>0)
			{
				sumtc+=t;
				c++;
			}
			else if(t<0)
			{
				sumts+=-t;
				s++;
			}
		}
		if(!c)
		{
			printf("Case %d: inf\n",cs++);
			continue;
		}
		int fz=sumtc+sumts;
		int fm=n-s;
		int b=__gcd(fz,fm);
		fz/=b;
		fm/=b;
		printf("Case %d: %d/%d\n",cs++,fz,fm);
	}
}

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值